Closed Bug 1730721 Opened 3 months ago Closed 3 months ago

Record Firefox Suggest prefs in telemetry environment

Categories

(Firefox :: Address Bar, task, P1)

task
Points:
1

Tracking

()

VERIFIED FIXED
94 Branch
Iteration:
94.1 - Sep 6 - Sept 19
Tracking Status
firefox92 --- verified
firefox93 --- verified
firefox94 --- verified

People

(Reporter: adw, Assigned: adw)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

As part of the Firefox Suggest offline/online rollouts, we want to record the following prefs in telemetry environment:

browser.urlbar.suggest.quicksuggest
browser.urlbar.suggest.quicksuggest.sponsored

See the discussion in bug 1729970.

Attached file request.md
Attachment #9241173 - Flags: data-review?(chutten)

Comment on attachment 9241173 [details]
request.md

PRELIMINARY NOTES:
Please ensure you document the userPrefs in the dedicated section of the Environment's docs

We don't expect people to have to read code to get at data documentation.

DATA COLLECTION REVIEW RESPONSE:

Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes.

Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, Drew Willcoxon is responsible.

Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, Interaction.

Is the data collection request for default-on or default-off?

Default on for all channels.

Does the instrumentation include the addition of any new identifiers?

No.

Is the data collection covered by the existing Firefox privacy notice?

Yes.

Does the data collection use a third-party collection tool?

No.


Result: datareview+

Attachment #9241173 - Flags: data-review?(chutten) → data-review+
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/589dee0c94f5
Record Firefox Suggest prefs in telemetry environment. r=daleharvey
Flags: qe-verify+
Flags: in-testsuite-

STR for QA

  1. New profile with Firefox Suggest offline enabled
  2. Open about:telemetry#environment-data-tab_settings and verify that the following values are true:
userPrefs.browser.urlbar.suggest.quicksuggest
userPrefs.browser.urlbar.suggest.quicksuggest.sponsored
  1. Open about:preferences#privacy-locationBar and uncheck one or both of the Firefox Suggest checkboxes
  2. Reload about:telemetry and verify that the corresponding values have been updated.
  • If you unchecked only the main checkbox, userPrefs.browser.urlbar.suggest.quicksuggest should be false but userPrefs.browser.urlbar.suggest.quicksuggest.sponsored should remain true
  • If you unchecked the sponsored checkbox, userPrefs.browser.urlbar.suggest.quicksuggest.sponsored should be false
  • Of course if you unchecked both, both values should be false
  1. It's not really necessary but if you'd like, repeat steps 3 and 4 and toggle the checkboxes in a different way and verify that the telemetry values are correct

It shouldn't be necessary to repeat with the online scenario. (And ultimately when all bugs have been fixed and the patches have been uplifted, I'd like to coordinate with you to fully test both offline and online, including this bug and others. I'll send an email later.)

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
  • I have tested this issue using the latest Nightly 94.0a1 (Build ID: 20210917093507) build on Windows 10 x64, macOS 11.6 and Linux Ubuntu 20.04 x64.
  1. I have enabled the Offline scenario by setting my region to US.
  2. I have checked the value of the userPrefs.browser.urlbar.suggest.quicksuggest and userPrefs.browser.urlbar.suggest.quicksuggest.sponsored probes in the telemetry panel.
  • This step fails since the value of the probes above is FALSE instead of true.

3&4. Unchecking any of the checkboxes will not change the probes' value since it was already set as false as per the result from step 2.

I have discussed with Drew this behavior and it seems that the issue appears only if the region was previously a non-US one.
For users that are located in the US, the behavior described in this comment does not apply.

Drew will investigate this odd behavior, so I will wait for more information before changing any flags.
Thank you.

Comment on attachment 9241170 [details]
Bug 1730721 - Record Firefox Suggest prefs in telemetry environment.

Beta/Release Uplift Approval Request

  • User impact if declined: Needed for important Firefox Suggest rollouts on 93 and 92
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Note about Nightly verification: Please see comment 7. This patch is necessary but due to a problem unrelated to this patch (in TelemertyEnvironment), the required telemetry is not properly recorded. Carmen and I have discussed the issue. We need to uplift this patch and then another one later (in a bug I will file soon) that fixes the unrelated problem.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This only adds two prefs to telemetry environment. No visible changes for users.
  • String changes made/needed:
Attachment #9241170 - Flags: approval-mozilla-release?
Attachment #9241170 - Flags: approval-mozilla-beta?
Depends on: 1731373

Comment on attachment 9241170 [details]
Bug 1730721 - Record Firefox Suggest prefs in telemetry environment.

Approved for 93.0b7.

Attachment #9241170 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This should be fixed by bug 1731373. Carmen, for tracking purposes I think we should mark this bug verified with the caveats we've discussed here, and then we should verify that bug 1731373 fixed the caveats, i.e., that the STR in comment 5 actually work.

QA Whiteboard: [qa-triaged]

Based on comment 11 and the fact that I have verified the fix in bug 1731373 on Nightly 94, I am also marking this bug as verified for the same channel. Will update the flag for 93 after verifying bug 1731373 in the Beta 93 channel as well.

Status: RESOLVED → VERIFIED

Comment on attachment 9241170 [details]
Bug 1730721 - Record Firefox Suggest prefs in telemetry environment.

Approved for 92.0.1.

Attachment #9241170 - Flags: approval-mozilla-release? → approval-mozilla-release+

Based on comment 11 and the fact that I have verified the fix in bug 1731373 using the Candidate 92.0.1 build (Build ID: 20210920202613), I am also marking this bug as verified for the same channel. Will update the flag for 93 after verifying bug 1731373 in the Beta 93 channel as well.

Based on comment 11 and the fact that I have verified the fix in bug 1731373 using the Firefox Beta 93.0b8 build (Build ID: 20210921185902), I am also marking this bug as verified for the same channel.

Flags: qe-verify+
See Also: → 1734447
You need to log in before you can comment on or make changes to this bug.