Closed Bug 1731243 Opened 1 month ago Closed 17 days ago

20.48 - 11.78% tp5o responsiveness / tp5o_webext responsiveness + 1 more (Linux) regression on Tue September 14 2021

Categories

(Core :: DOM: Content Processes, defect, P1)

defect

Tracking

()

RESOLVED WONTFIX
Fission Milestone MVP
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 --- wontfix

People

(Reporter: aesanu, Assigned: nika)

References

(Regression)

Details

(4 keywords)

Perfherder has detected a talos performance regression from push 151359d48f18d5569f3ef5b46b901b9e666ccc28. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

Ratio Test Platform Options Absolute values (old vs new)
20% tp5o responsiveness linux1804-64-shippable-qr e10s fission stylo webrender 5.27 -> 6.35
19% tp5o responsiveness linux1804-64-shippable-qr e10s fission stylo webrender 5.32 -> 6.35
12% tp5o_webext responsiveness linux1804-64-shippable-qr e10s fission stylo webrender 6.93 -> 7.74

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) will be backed out in accordance with our regression policy.

For more information on performance sheriffing please see our FAQ.

Flags: needinfo?(nika)
Fission Milestone: --- → ?

Tentatively assigning to Nika because this is a regression from her fix for bug 1729458.

Assignee: nobody → nika
Fission Milestone: ? → MVP
Priority: -- → P1

After some discussion in #fission on matrix a few days ago, we think that this is probably caused by us not yielding to the main thread in the parent process as often when doing a process switch, which was an intentional decision for that bug. We're unsure if there are real-world negative impacts of this change, so we're considering WONTFIXing the regression.

Flags: needinfo?(nika)

Nika and Randell confirmed that we can WONTFIX this bug.

Status: NEW → RESOLVED
Closed: 17 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.