Closed Bug 1731606 Opened 2 months ago Closed 2 months ago

Unable to move the 'Print' / new preview so it does not prevent access to all of Thunderbird.

Categories

(Thunderbird :: General, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: anjeyelf, Unassigned)

References

(Depends on 1 open bug)

Details

Select email and use Menu app icon > Print or Ctrl+P
New Print Preview opens

This is not in a separate window or tab and is fixed, so you cannot move it.
You cannot leave as it is and go back to read emails or access calendar or access anything.
With Print open you are prevented from doing anything in Thunderbird.

You cannot go back to list of emails and select to Print (Preview) another email, so being able to go through various emails or Calendar and stack up a separate list of windows which you will print as a print job at a later time.

Selecting Print to see preview now stops and prevents all access to Thunderbird.

Print needs to open in a new window, so it can be moved, so you can select other items that need to be printed. So you can access Thunderbird to read emails etc.

Selecting Print should not block continued access to all of Thunderbird.

If you're doing to print something, why would you need to go back and forth between other parts. When you need that, you can just close the preview and go to the other part, then it's half a second and you're back into print preview.

The printing code relies on printing what's shown. We won't be moving it to a separate window.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WONTFIX

The only problem that I see is, that when I select another tab the print preview stays on top. The preview should be tab modal.

Well it's ok if you only want to print one item and want to print it at that moment.

The new print preview is not an improvement.

The current workaround forced on Users:
Select email so contents appears in Message Pane - decide it requires a print.
Now Open the email in a new window. (additional right click and left click per item - not exactly anti-RSI)
Move window to suitable location
Select the option to Print to see Print Preview
Repeat the above to get stacks of opened emails with a print preview.

After printing it now also requires you to close the opened email windows - more additional clicks.
I would not call the above efficient nor an improvement nor does it help if you perform more clicking and do not want RSI issues.

If you can create the print preview so it is purely in a tab, it is an improvement providing you can select several. But cluttering up Thunderbird with loads of those types of tabs is not the best method when new windows which can be stacked work perfectly.

It is not correct to block all access to Thunderbird just because you want to select print jobs.

I fail to see why anyone would like to queue things up like that: if you want to print, you click print and then move on to other things - even if you have multiple things you want to print.

(In reply to Magnus Melin [:mkmelin] from comment #4)

I fail to see why anyone would like to queue things up like that: if you want to print, you click print and then move on to other things - even if you have multiple things you want to print.

And that is why there is a problem because as you say you are failing to see....People have different work practises which suits how they work and this should be recognised as valid and not dismissed just because someone else does things differently.

I have a perfectly valid reason for asking why would anyone create a design that can - even temporarilly - blocks all access to the rest of Thunderbird.
If I wanted to check on anything I would have to Cancel or Print and that situation should not arise.
It is perfectly reasonable to leave a print open and ready to perform and still have access to emails or calendar etc.

You should not be forced to perform weird workarounds where you either have to have emails open in a new window or even open a second Thunderbird window to continue to show folders or calendar etc.

If you had a design where you opened an email to read and it blocked all access to all of Thunderbird whilst it was open, it would be considered a bad idea, so I'm saying that same email now opened as a print job and blocking access is also a bad idea.

(In reply to Richard Marti (:Paenglab) from comment #2)

The only problem that I see is, that when I select another tab the print preview stays on top. The preview should be tab modal.

That is one of the various problems and you are correct.
I'm surprised this topic should even be required as having anything open in any way that blocks accessibility to all of Thunderbird is wrong as a basic design concept. Forcing the user to get on with printing or cancel is not okay. It should not happen in the first place.

Just in case no one has noticed - this does not occur in Firefox.
I can move to another tab and the print preview does not stay on top.
This means if desired you can open the same tab in another tab and not have the 'print preview' move as well.

The 'print preview' does not block access to anything in Firefox, so why is it doing it in Thunderbird.

This bug should be reopened.

This isn't an issue for someone who has opened a message in it's own window.

So the problem is about being tab modal. And I think the print issue should go away when the main pane is reworked in bug 1729379

Depends on: tb-new-3pane
You need to log in before you can comment on or make changes to this bug.