Closed Bug 1732108 Opened 2 months ago Closed 2 months ago

Implement/fix mappings for ins, del elements and insertion, deletion roles

Categories

(Firefox :: Disability Access, defect)

defect

Tracking

()

RESOLVED FIXED
94 Branch
Tracking Status
firefox94 --- fixed

People

(Reporter: jdiggs, Assigned: Jamie)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Steps to reproduce:

  1. Load data:text/html,<ins>foo</ins> <del>bar</del>
  2. Use a platform accessibility inspector (e.g. Accerciser) to examine the roles

Expected results:

  • Insertion would be exposed as ROLE_CONTENT_INSERTION in ATK and IA2
  • Deletion would be exposed as ROLE_CONTENT_DELETION in ATK and IA2

Actual results:

  • Both are exposed as ROLE_SECTION in ATK

Changing the test case to use the ARIA 1.2 deletion and insertion roles produces the same results.

Support for the ins/del elements (and mapping to IA2) was added in bug 903187. We didn't add support for ATK then because the ATK roles didn't exist then (see bug 903187 comment 11). Support for the ARIA roles was added in bug 1540813.

So, it's just the ATK roles we need to map here.

Implementation note: Add the new roles in RoleMap. Add a fallback for these roles if !IsAtkVersionAtLeast(2, 34) here.

Blocks: aria
Severity: -- → S3
Depends on: 1540813, 903187

Joanie, do you have a moment to test this try build? If not, I'll try to get set up to verify it myself here (or have someone else on my team do it); it just might take a while.

Flags: needinfo?(jdiggs)
Assignee: nobody → jteh
Status: NEW → ASSIGNED

Tried and verified. Thanks so much!

Flags: needinfo?(jdiggs)
Blocks: 1732280
Pushed by jteh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/565c8f463041
Map ATK_ROLE_CONTENT_DELETION/INSERTION. r=eeejay
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
No longer blocks: 1732280
You need to log in before you can comment on or make changes to this bug.