Blue selection on image-submit-button. Should be dotted line.

RESOLVED FIXED

Status

()

Core
Selection
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: José Jeria, Assigned: mjudge)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021007

Now that you can select images in Mozilla as well, when you tab in a form and
the submit button is an image, it gets the blue selection.
When the submit button gets selected the dotted line should appear instead.

For example, go to 
http://www.gamespot.com

focus the search filed and press the TAB button. 

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

16 years ago
Created attachment 102143 [details]
Testcase.

This is another example with image selection weirdness.
Press tab to focus the image, the dotted rectangle appears around the image
(correct), then press tab again to focus the link.

Now press SHIFT + TAB for going back to the image. The image gets the blue
selection and not the dotted selection.
Why is it getting selected at all?  It should just be focused...

Comment 3

16 years ago
I noticed this on linked images as well, why are they appearing selected?

Who recently implemented selection appearance for images?
(Reporter)

Comment 4

16 years ago
Looks like several people implemented the selection of images. See bug 14835.

Comment 5

16 years ago
confirming based on recent comments
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 6

16 years ago
I have a fix for this posted in 

http://bugzilla.mozilla.org/show_bug.cgi?id=174163
Bug 174163 - Unselecting image shows it in reverse-video

I would just like to use that bug to get this r,sr ect and into tree.   Simply
because I posted patch there first ;)
Status: NEW → ASSIGNED
(Assignee)

Updated

16 years ago
Depends on: 174163
(Reporter)

Comment 7

16 years ago
Created attachment 108341 [details]
Screenshot

I know there is a fix for this in bug 174163, but anyway, this is how the the
submit button looks on gamespot.com,
tabbing to it selects the image, clicking on the text field gives it an
inverted selection.

Comment 8

16 years ago
checked in as part of bug 170921
(Reporter)

Comment 9

16 years ago
Now that bug 170921 has been checked in this works fine. 2003030908, Windows 
2000.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.