Closed Bug 1732583 Opened 1 year ago Closed 11 months ago

No subpixel anti-aliasing for folders, mail list, menu, settings dialogs with WebRender

Categories

(Thunderbird :: Untriaged, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1724057

People

(Reporter: iam, Unassigned)

References

Details

Attachments

(5 files)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:92.0) Gecko/20100101 Firefox/92.0

Steps to reproduce:

Thunderbird 91.1.0 on Fedora Linux 34 does not have subpixel anti-aliasing for mail folders, mail list, menus and all internal dialogs.
The email content, tabs and some titles have anti-aliasing.

This is due to WebRender switch in Firefox, which is also affected: https://bugzilla.mozilla.org/show_bug.cgi?id=1724057

Actual results:

No subpixel anti-aliasing is used in many elements. Grayscale anti-aliasing is used instead.

Expected results:

Subpixel anti-aliasing should be used for all elements, as in previous versions of Thunderbird 78.

RED is where grayscale anti-aliasing is used
GREEN is where subpixel anti-aliasing

BIG version of the previous image

Attached image Drop-down menu

No subpixel anti-aliasing in the menu.

Attached image Preferences menu

No subpixel anti-aliasing in preferences.

BIG version of the previous image

like bug 1729198 ?

Flags: needinfo?(iam)

(In reply to Wayne Mery (:wsmwk) from comment #6)

like bug 1729198 ?

I would guess that's the same bug, but I'm not sure. In my case, Thunderbird does not ignore anti-aliasing settings, it just uses grayscale anti-aliasing in some places instead of subpixel anti-aliasing.

In Firefox, this is WebRender engine issue caused by a feature: for animations and text with some effects (text rotation), it disables subpixel anti-aliasing to make text look better, but in this case there's no visible effects or rotation, and this feature is applied incorrectly.

Flags: needinfo?(iam)
See Also: → 1733808
Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1724057

Darkspirit, this bug is for Thunderbird, while that bug is for Firefox.

(In reply to ValdikSS from comment #9)

Darkspirit, this bug is for Thunderbird, while that bug is for Firefox.

Firefox and Thunderbird themselves are like super-addons running on Gecko (=Firefox without chrome. Chrome is the technical term for browser UI.).
The Discord desktop app is like a super-addon running on Blink (=Chromium/"Google Chrome" without chrome.).

This regression in font rendering makes Thunderbird 91 not usable for me... The list of emails (subjects) became very hard to read.

ROSA Linux rosa2021.1
$ rpm -q --whatprovides freetype
lib64freetype6-2.10.4-4.x86_64
$ rpm -q --whatprovides fontconfig
fontconfig-2.13.94-3.x86_64

(In reply to Mikhail Novosyolov from comment #11)

This regression in font rendering makes Thunderbird 91 not usable for me... The list of emails (subjects) became very hard to read.

ROSA Linux rosa2021.1
$ rpm -q --whatprovides freetype
lib64freetype6-2.10.4-4.x86_64
$ rpm -q --whatprovides fontconfig
fontconfig-2.13.94-3.x86_64

This has to do with TB WebRender integration and not the font packages you listed. You can disable WebRender by doing ...

  1. Go to Preference -> General -> Config Editor

  2. Enter "gfx.webrender.force-disabled" without the quotes.

  3. Toggle the setting and restart.

Setting gfx.webrender.force-disabled=true helped! But it is a critical bug for out of the box user experience.

Maybe just turn of webrender out of the box for now? I don't think that webrender is much needed to render text and images in Thunderbird.

We had very few reports of it being a problem.
Non-webrender is going away, and I think on trunk pretty much of it removed already.

(In reply to Magnus Melin [:mkmelin] from comment #15)

We had very few reports of it being a problem.

I spotted numerous messages on Russian forums that newer versions of Firefox/Thunderbird have "broken fonts", and they blame Mozilla for "ongoing Microsoft campaign to break fonts on lowDPI screens" (because Microsoft had/have the same issue in UWP applications under some circumstances since 8.1 I guess).
Can't say for the rest of the world, but many non-savvy Russian users don't know how and where should they report such bugs and don't speak English.

As this is a bug tracker and not a discussion platform, I'm just politely waiting this issue to be eventually fixed, but in fact I'm very disappointed that no-subpixel rendering
a) haven't been noticed among the developers
b) is not a blocker
c) takes so long to fix

On my 10-year-old 1366×768 laptop screen grayscale rendering looks very uncomfortable, given that I have 25% better eye sharpness than the average person. Good thing that it does not affect the website contents (only panels etc), otherwise it would be a catastrophe which made me switch the browser in a day.

It's unclear if webrender is responsible for those. I'd imagine bug 1729198 is a more major problem, but how/if webrender plays into that I don't know.

Good thing that it does not affect the website contents (only panels etc), otherwise it would be a catastrophe which made me switch the browser in a day.

For Thunderbird it is a catastrophe because text is the only and main content here and it became hard to read.
Both English and Russian text is broken, of course.

Of course there are HiDPI monitors and screens but very few desktops or laptops have them.

(In reply to Magnus Melin [:mkmelin] from comment #17)
It's unclear if webrender is responsible for those. I'd imagine bug 1729198 is a more major problem, but how/if webrender plays into that I don't know.

That bug is a duplicate of this one. Note the place where fonts are incorrect according to it: "Folderpane and message list". This bug is about the same.

You need to log in before you can comment on or make changes to this bug.