download dialog comes up even though FTP server can't be found

VERIFIED FIXED in mozilla1.2beta

Status

()

Core
Networking: FTP
--
major
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Judson Valeski, Assigned: dougt)

Tracking

Trunk
mozilla1.2beta
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
problem: when visiting said URL, can clicking on the "301 or later" download
link in the right column, a save-as dialog is thrown, then a download progress
dialog. a file of zero length gets created on the file system, however, the ftp
server isn't even accessible.

expected results: a dialog gets thrown telling the user the server can't be reached.
(Assignee)

Updated

16 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2beta
dupe of the old bug 63798

*** This bug has been marked as a duplicate of 63798 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

16 years ago
not so fast....  this is clearly a new regression.  
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

16 years ago
the nsOnStopRequestEvent depends on the request having the a valid status. 
however, we are not setting the internal state before making use of this event.  

This patch fixes it for me.

Index: nsFtpConnectionThread.cpp
===================================================================
RCS file: /cvsroot/mozilla/netwerk/protocol/ftp/src/nsFtpConnectionThread.cpp,v
retrieving revision 1.250
diff -u -r1.250 nsFtpConnectionThread.cpp
--- nsFtpConnectionThread.cpp	30 Sep 2002 21:50:17 -0000	1.250
+++ nsFtpConnectionThread.cpp	9 Oct 2002 04:55:34 -0000
@@ -2381,6 +2381,8 @@
     if ( NS_SUCCEEDED(broadcastErrorCode))
         broadcastErrorCode = mInternalError;
 
+    mInternalError = broadcastErrorCode;
+
     if (mDPipeRequest && NS_FAILED(broadcastErrorCode))
         mDPipeRequest->Cancel(broadcastErrorCode);
     

Can I get a r/sr?  

Comment 4

16 years ago
sr=darin

Comment 5

16 years ago
r=neeti
sorry for incorrect duping....
a=dbaron for trunk checkin
(Assignee)

Comment 8

16 years ago
I landed this sometime last week.  Marking Fixed.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 9

16 years ago
Build: 2002-10-25-04-trunk

A dialog appears indicating server cannot be reached.  This reflects expected
behavior.  Marking Verified!
Status: RESOLVED → VERIFIED
QA Contact: benc → jimmylee
You need to log in before you can comment on or make changes to this bug.