Closed Bug 1733384 Opened 4 months ago Closed 4 months ago

Update inert to match the recent CSSWG resolutions.

Categories

(Core :: DOM: Core & HTML, task)

task

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

No description provided.
Flags: needinfo?(emilio)

This matches the consensus from the CSSWG call.

Depends on D127422

Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/65708a4c708f
Make inert not modify the computed style. r=sefeng,layout-reviewers,jfkthame
https://hg.mozilla.org/integration/autoland/rev/1a073e40ab1a
Allow explicitly-inert modal dialog to be inert. r=sefeng
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/31152 for changes under testing/web-platform/tests
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/dd1936d9fe17
Enable inert in the new dialog test.
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/fa609fadac26
Remove some asserts from a test that no longer pass because inert is no longer observable from the computed style.
Upstream PR was closed without merging
Attachment #9244172 - Attachment description: Bug 1733384 - Allow explicitly-inert modal dialog to be inert. r=ntim,sefeng,#layout-reviewers → Bug 1733384 - Allow explicitly-inert modal dialog to be inert. r=sefeng
Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1732eccd98e8
Make inert not modify the computed style. r=sefeng,layout-reviewers,jfkthame
https://hg.mozilla.org/integration/autoland/rev/052cbf82beba
Allow explicitly-inert modal dialog to be inert. r=sefeng
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Upstream PR was closed without merging
Upstream PR merged by moz-wptsync-bot
Upstream PR merged by moz-wptsync-bot
Regressions: 1736370
No longer blocks: 921504
Depends on: 921504
You need to log in before you can comment on or make changes to this bug.