Move assigned_to change field into main body of bug form

RESOLVED FIXED in Bugzilla 3.2

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED FIXED
16 years ago
11 years ago

People

(Reporter: gerv, Assigned: Frédéric Buclin)

Tracking

2.17
Bugzilla 3.2

Details

(Whiteboard: [blocker will fix])

The assigned_to field is currently changed down in the knob. This is
inconsistent, and gives rise to a class of bugs like "I want to reassign the bug
and also do X". We should move it up into the body of the bug, and make it
independently editable.

Gerv
We need to decide what happens in the following cases:

- Bug is ASSIGNED, and is reassigned
- Bug is NEW/UNCONFIRMED/REOPENED, and is reassigned

Ideally, the "reassign to owner and QA of selected component" function would be
up in the main body of the bug too; this leaves only status and resolution
changes in the knob, which makes sense. However, this is hard to implement
UI-wise unless you are using a dropdown to choose the assignee, which won't be
true in all cases. Alternatively, you could reassign it to the owner and QA of
the selected component if you clear the field, but that's not very discoverable.
Is that a problem?

Gerv

*** Bug 278587 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
There could be a checkbox - "reassign to defualt owner" beside or beneath the
AssignedTo and QA Contact boxes, too.

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa
(Assignee)

Updated

12 years ago
Assignee: myk → create-and-change
(Assignee)

Updated

11 years ago
Depends on: 92552
(Assignee)

Comment 4

11 years ago
(In reply to comment #3)
> There could be a checkbox - "reassign to defualt owner" beside or beneath the
> AssignedTo and QA Contact boxes, too.

Yes, that's what we implemented in bug 92552.
Assignee: create-and-change → LpSolit
Severity: normal → enhancement
Whiteboard: [blocker will fix]
Target Milestone: --- → Bugzilla 3.2
(Assignee)

Comment 5

11 years ago
Bug 92552 has been checked in.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.