Closed Bug 1734449 Opened 11 months ago Closed 10 months ago

"Create account" Missing support for OAuth2 if manually entering one of the supported servers

Categories

(Thunderbird :: Account Manager, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1622181

People

(Reporter: essin, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image tbird.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:93.0) Gecko/20100101 Firefox/93.0

Steps to reproduce:

Started to add a new mail account for an office365 account.

Actual results:

The configure manually option does not offer OAuth2 as an option.
Editing an existing account does.

Expected results:

Should have seen OAuth2 in the dropdown

Component: Untriaged → Account Manager

It will only show if the O365 server has been found for that address.
OAuth2 can't be used with any server - it has to match the hostname.

Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → INVALID

Sorry but you are wrong. It doesn't with the o365 server either.
See second image

You mean when you manually filled in the server names? Yes it doesn't show it for that case.
But if you let it discover, and then go to this screen through the manual config link, then it will allow you to select.

Yes, when I enter it manually. What is the down-side of displaying OAuth2 in the dropdown, just like it does in the server settings for an existing account? It would seem to make the code less complicated to re-use that list rather than maintaining two.

I can't imagine that there are not situations in which auto-discover fails.

I guess we could dynamically add/show OAauth2 based on server yes.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
Summary: "Create account" Missing support for OAuth2 → "Create account" Missing support for OAuth2 if manually entering one of the supported servers
Status: REOPENED → NEW

I think the point here is the option of authentication method as oath are not displayed for a normal account when the server name is changed, only when the page is reloaded after the server is changed by exiting the server settings and returning to them, much less convenient than clicking a retest button to reload them as here.

All I can tell you is that I'm no novice but, in the absence of documentation, it was not obvious to me that "Detect" would find an auth method the was not in the list. I just assumed that TB was way behind the time and filed the report. I wasted over an hour my time, and some of yours, before I figured it out. User-friendly and intuitive it is NOT.

Thanks

Blocks: tb91found
Status: NEW → RESOLVED
Closed: 10 months ago10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1622181
You need to log in before you can comment on or make changes to this bug.