Closed Bug 1734698 Opened 4 months ago Closed 4 months ago

The highlight border of the default button is not displayed even if with Default(system) theme. And also no mouse hover feedback

Categories

(Firefox :: Theme, defect)

Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 --- unaffected
firefox95 + verified

People

(Reporter: alice0775, Assigned: emilio)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

Attached image image.png

Stes To Reproduce:

  1. Start firefox.exe -p
    --- observe
  2. Open Dialog (not tab modal dialog)
    such as Password Required import From Another Browser
    --- observe

Actual results:
No highlight border for default button

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3864fbda86cb6cdfed2353be3e39edca79735221&tochange=cc9028cb90d72d12c13e2af25a996abfcd68ecba

And also no mouse hover feedback.

Summary: The highlight border of the default button is not displayed even if with Default(system) theme → The highlight border of the default button is not displayed even if with Default(system) theme. And also no mouse hover feedback

Hmm, that's not right, we shouldn't use the non-native theme there if the system is light.

Flags: needinfo?(emilio)
Assignee: nobody → emilio
Flags: needinfo?(emilio)

Oversight from the regressing bug, without this we always draw supported widgets
with the non-native theme, even when the native theme also supports it.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c1acf3eec350
Override nsNativeThemeWin::CreateWebRenderCommands. r=mstange
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

The patch landed in nightly and beta is affected.
:emilio, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

Beta is not affected afaict.

Flags: needinfo?(emilio)
Flags: qe-verify+

Reproduced with Fx 95.0a1 (2021-10-07) on Windows 10.
Verified fixed with Fx 96.0a1 (2021-11-02) and Fx 95.0b2 on Windows 10.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.