Closed Bug 1734767 Opened 1 year ago Closed 1 year ago

Light themes - Improve visibility for key icon in saved logins dropdown

Categories

(Firefox :: about:logins, defect)

defect

Tracking

()

VERIFIED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox93 --- unaffected
firefox94 + verified
firefox95 --- verified

People

(Reporter: cfogel, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image fb.png

Affected versions

  • 95.0a1(20211007091917), 94.0b3

Affected platforms

  • Win10;
  • will check other OSs when time permits it;

Steps to reproduce

  1. Launch Firefox and save a few logins on https://www.facebook.com/
  2. Access https://www.facebook.com/
  3. Click inside the user/pass fields and hover over the available logins/passwords;

Expected result

  • key icon is visible;

Actual result

  • colors are to close one to another

Regression range

  • will check when time permits it;

Additional notes

  • on dark theme it's a bit more visible;
  • attached screenshot with the issue.

Not a regression.
Visible with addition of Monochromatic themes: such as Graffiti balanced, Cheers soft, Abstract Bold, Foto Balanced.

Summary: Improve visibility for key icon in saved logins dropdown → Monochromatic themes - Improve visibility for key icon in saved logins dropdown

set theme on Light.
Got the range:
good: 2021-10-01
bad: 2021-10-02
pushlog: URL
mozregression pointed towards bug 1733354 as being at fault.

Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression
Regressed by: 1733354
Summary: Monochromatic themes - Improve visibility for key icon in saved logins dropdown → Light themes - Improve visibility for key icon in saved logins dropdown

The Bugbug bot thinks this bug is a defect, but please change it back in case of error.

Type: enhancement → defect
Depends on: 1734297

I used mozregression --find-fix and this issue was fixed by bug 1734297.

First good revision: b94153cca1f7d677fbbcc1a0d4923d81ddec8958
Last bad revision: ef7b596bb385f46280eb1492009bf8fb541e17db
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ef7b596bb385f46280eb1492009bf8fb541e17db&tochange=b94153cca1f7d677fbbcc1a0d4923d81ddec8958

Set release status flags based on info from the regressing bug 1733354

This is a visual regression in the default light theme.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1734297

Hmm, if this is an issue in 94 we should probably fix it.

Flags: needinfo?(emilio)

Let's un-dupe this then and call it fixed on 95 by bug 1734297. I'm not sure we want to try backporting that bug to Beta, though, so agreed with trying to find a more scoped fix here instead.

Resolution: DUPLICATE → FIXED
Target Milestone: --- → 95 Branch
Assignee: nobody → emilio

Comment on attachment 9245676 [details]
Bug 1734767 - [beta] Don't override Graytext on windows dark mode. r=dholbert

Beta/Release Uplift Approval Request

  • User impact if declined: Comment 0
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Make graytext return light colors like most other system colors on beta.
  • String changes made/needed: none
Flags: needinfo?(emilio)
Attachment #9245676 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I was not able to reproduce this on an affected Nightly build, neither using dark or light theme. I see no difference between the Nightly from 2021-10-07 and the one from 2021-10-14.
The only way I can reproduce this issue is on a 94 Beta build, with Dark theme enabled at OS level.
Tested on: Windows 10x64.

Emilio, any thoughts about this?

Flags: needinfo?(emilio)

The range of affected nightlies is pretty small, so not super-surprising. I could probably find one that repros but it's not a big deal IMO. We should just fix the bug in beta by uplifting comment 11.

Flags: needinfo?(emilio)

Comment on attachment 9245676 [details]
Bug 1734767 - [beta] Don't override Graytext on windows dark mode. r=dholbert

Approved for 94.0b6

Attachment #9245676 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

(In reply to Ryan VanderMeulen [:RyanVM] from comment #15)

https://hg.mozilla.org/releases/mozilla-beta/rev/7692ec3287f9

This specific commit was backed out as part of the rebasing effort for bug 1734115. The end result of the fix is still in place, however.
https://hg.mozilla.org/releases/mozilla-beta/rev/59b63f067f11

The issue is verified as fixed on latest Beta 94.0b6, Win 10x64. I also verified that the fix didn't affect the behavior on Nightly.

I have noticed that on macOS and Linux with Dark mode enabled at OS level, using the System theme, the panel has a dark background, but on Windows has a white background. Is this intended or should I log a new issue for this?

Status: RESOLVED → VERIFIED
Flags: needinfo?(emilio)
Flags: qe-verify+

Yeah, that's expected on Windows because we don't have dark mode support in beta.

Flags: needinfo?(emilio)
You need to log in before you can comment on or make changes to this bug.