Closed Bug 1734297 Opened 1 year ago Closed 1 year ago

Bad dark mode contrast for name textbox in Create Profile Wizard

Categories

(Toolkit :: Themes, defect)

Desktop
Windows
defect

Tracking

()

VERIFIED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox92 --- unaffected
firefox93 --- unaffected
firefox94 --- disabled
firefox95 --- verified

People

(Reporter: mathew.hodson, Assigned: emilio)

References

(Regressed 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(3 files)

In dark mode, when entering test in the textbox as part of the Create Profile Wizard, the text is unreadable.

Affects Windows at least.

Last good revision: 1ff04e10cd2318b494c0f05777cd80291289d127
First bad revision: d39b23efefe7e7d89d8dfd0ba188ad6af2b0a9ed
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=1ff04e10cd2318b494c0f05777cd80291289d127&tochange=d39b23efefe7e7d89d8dfd0ba188ad6af2b0a9ed

Regressed by: 1733569
Component: CSS Parsing and Computation → Widget
Flags: needinfo?(emilio)

Set release status flags based on info from the regressing bug 1733569

Depends on: 1734226
Flags: needinfo?(emilio)

Also, change XUL button borders to match HTML <input>s and <button>s.

Depends on D127624

Assignee: nobody → emilio
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

The menulist inherits white -moz-dialogtext but still has a white background.

Also, can we just the titlebar for these dialogs and make a xul replacement, as in the main chrome doc? Alternatively, is there any kind of windows API to make the titlebars adapt to windows color mode, the way UWP apps do?

It's a matter of taste of course but I find the contrast pretty jarring and janky looking. Although I really prefer dark mode, I'd rather the dialog be all white than be dark with a white titlebar.

I feel the same way about places.xhtml, it's supported dark mode for a while but I find myself avoiding it because of the huge white titlebar running across the top.

On a different but related note, on Windows 10 when you resize a window with the mouse (like, dragging an edge/corner) you can see a white "frame" behind the window's content. In light mode it's not apparent but in dark mode it sticks out like a sore thumb. It resizes along with the content, but there's a slight delay so it lags behind by a couple frames or something. Even at 60Hz it's visible when moving the mouse quickly enough, but at 120+ it's really quite extreme, so I've taken to using displayfusion hotkeys to resize the window instead.

(In reply to aminomancer from comment #3)

Also, can we just the titlebar for these dialogs and make a xul replacement, as in the main chrome doc?

*Whoops, I meant to say "Also, can we just hide the titlebar for these dialogs..."

Hah, I literally just sent a patch for the titlebar in bug 1734359. About that menulist, mind filing a separate bug and ni? me? Happy to look into it.

Flags: needinfo?(shmediaproductions)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/26d16ea90c8c
Don't use native <input> appearance on Windows dark mode. r=desktop-theme-reviewers,dao
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Component: Widget → Themes
OS: Unspecified → Windows
Product: Core → Toolkit
Target Milestone: 95 Branch → ---
Blocks: 1734948
Blocks: 1734767

I think the underlying issue with the badly contrasting colors was introduced in bug 1731678.

Some dark mode colors were disabled in bug 1733354, so the Profile Manager dialog isn't affected in Firefox 94. They were enabled again in bug 1733569.

Maybe this patch could be uplifted since it seems to fix some other theme bugs in Firefox 94.

Depends on: 1733569, 1733354
Regressed by: 1731678
No longer regressed by: 1733569
Has Regression Range: --- → yes
Blocks: 1734367
Flags: qe-verify+

Reproduced this on an affected Nightly build 95.0a1 (20211005094529) on Win 10x64.

Verified as fixed on Beta 95.0b2 (20211102190739) on Win 10x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1734690
Flags: needinfo?(shmediaproductions)
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.