Closed Bug 1735043 Opened 2 months ago Closed 2 months ago

when message pane is not shown, print context menu and shortcut can still be used but no proper document can be printed (wontfix: Print is now disabled if message pane is hidden)

Categories

(Thunderbird :: General, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91+ fixed, thunderbird94+ verified)

VERIFIED FIXED
95 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird94 + verified

People

(Reporter: infobob, Assigned: mkmelin)

References

(Regression)

Details

(4 keywords, Whiteboard: [wontfix per Bug 1727107 Comment 11])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.81 Safari/537.36

Steps to reproduce:

Right click any unopened email and since Print Preview is NO LONGER listed I select Print option and the Print Dialog box appears along with Welcome to Thunderbird 2-page document in the Preview Screen. Sometimes a blank preview screen not displaying the contents of the email is displayed along with the Print Dialog box.
Note: The ability to Preview a suspect or any email without opening it was the single best feature in Thunderbird email. Please, please fix this bug quickly so I don't have to search for another email client program.

Actual results:

Print Dialog box appears along with Welcome to Thunderbird 2-page document in the Preview Screen. Sometimes a blank preview screen not displaying the contents of the email is displayed along with the Print Dialog box.

Expected results:

Contents of email should appear in the Preview box, not a Welcome message from Thunderbird or a blank screen.

The ability to Preview emails without opening them was the single best feature of the Thunderbird client email.

I don't think using right-click > Print opens the email, but it does have to be showing in the Message pane.

When I just right-click on a message in the Thread pane, and it doesn't appear in the Message pane, the Print menu item is disabled for me.

I can not reproduce your issue with a message selected, and visible in the Message pane.

Could you try Help > Troubleshoot Mode and see if an extension may be causing the problem?

Flags: needinfo?(infobob)

I don't know how I could make the issue more clear than stated in my original bug fix request. Any new unread emails in TB 78 I was able to right click on it and the drop down list contained an option to PRINT PREVIEW which is no longer there in 91.2.0 so now I have to select PRINT and the next screen should show both a Preview of the email contents on the left as well as the Print Dialog box on the right side of the screen. Unfortunately, the only preview my Windows 10 system is displaying is the 2-page Welcome to Thunderbird letter or a Blank screen.

Flags: needinfo?(infobob) → needinfo?(support)

Did you try Troubleshoot Mode as suggested?

Flags: needinfo?(infobob)

Affirmative. Tried Troubleshoot Mode several times with same results.

Strictly speaking you can't print something without opening it.
Even when you previously "printed without opening it", afaik it was in fact opening it.

Anyway, the redesigned print function can only print something which is displayed. From there you have print preview, and from preview you can generate the print.

Severity: -- → S4
Component: Untriaged → General
Flags: needinfo?(support)
Flags: needinfo?(infobob)

I MAJORED IN COMPUTER SCIENCE AT THE SCHOOL OF ENGINEERING. MY CLIENTS TELL ME I AM VERY ARTICULATE. WHY IS ALMOST EVERYONE HAVING DIFFICULTY UNDERSTANDING THE ISSUE. SOMEONE DID POST THIS SAME ISSUE.

  1. I HAVE BEEN USING TB FOR YEARS AND NOW THE PROBLEM AFTER THEY UPGRADED VERSION 78 TO VERSION 91.2.0
  2. I AM NOT TRYING TO PRINT THE EMAIL! I KNOW HOW TO PRINT EMAILS.
  3. I WANT TO PREVIEW AND READ THE CONTENTS OF THE EMAIL TO DETERMINE IF I WANT TO OPEN IT.
  4. THE NEW PRINT FUNCTION IS SUPPOSED TO DISPLAY THE CONTENTS OF THE EMAIL AND ALL I SEE IS A BLANK SCREEN.
  5. THE TROUBLESHOOT MODE DID NOT CHANGE ANYTHING.

Like Wayne wrote, yes you can no longer print something that you don't open, since the code is not designed to do so. (Earlier the document was also opened, only in the background.)

I'm curious as to why you'd preview an email by printing it? There wouldn't have been any security advantages if that's what you were after.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → INVALID

There wouldn't have been any security advantages if that's what you were after.

Agreed

I WANT TO PREVIEW AND READ THE CONTENTS OF THE EMAIL TO DETERMINE IF I WANT TO OPEN IT.

Just to be clear, "print preview" is no longer available as a menu item and isn't coming back. But when you choose "print" what you get IS print preview. But "print" is not available unless the message is selected AND displayed.

If "print" is offered for a message that is not displayed, then that is likely a bug. And may also be the reason why you see "Welcome to Thunderbird".

I don't know why you have such a difficulty in understanding the simple issue. I have been using TB for years. Any suspect email or email from any unknown sender I would simply highlight the email, NOT OPEN IT, and right click and select PREVIEW which would reveal the sender's email address and contents of the email WITHOUT MARKING THE EMAIL AS READ. I FULLY UNDERSTAND THAT IS NO LONGER AVAILABLE WITH 91.2.0, HOWEVER, THE PRINT OPTION DOES NOT DISPLAY THE CONTENTS OF THE EMAIL ONLY A WELCOME TO THUNDERBIRD SCREEN OR A BLANK PREVIEW SCREEN.
THEREFORE IT IS A BUG AND I WOULD APPRECIATE A FIX TO THE ISSUE. THANK YOU SO VERY MUCH.

No need to shout.

We probably couldn't confirm the bug because you did not provide enough information.

Do you have the Message Pane hidden using F8?

I can reproduce a blank preview with the Message Pane hidden, a message in the Thread Pane selected and clicking "Print".

Flags: needinfo?(infobob)

Hello WaltS48. It is very frustrating when people with serious programming experience, BS degrees in Computer Science and probably a great deal more knowledge about the email client application then me have great difficulty in understanding that the new combined Print function is only displaying the "Welcome to Thunderbird" two page message or a blank screen together with the Print Dialog box, NOT the contents of the unopened email. Using F8 yields the same as opening the email itself as it will change the Unread Status of the email to Read. There is obviously a bug in the programming of TB Version 91.2.0 and I will be patient until an update fixes it. This issue cannot be isolated to my Window 10 system as I did read other(s) complaining about the same issue. I have found a workaround though. Thank you.

Flags: needinfo?(infobob)

"This issue cannot be isolated to my Window 10 system as I did read other(s) complaining about the same issue. I have found a workaround though."

You could be more helpful by citing URLs to the other complaints.

DO YOU HAVE THE MESSAGE PANE ENABLED OR NOT?

I WAS TRYING TO HELP VERIFY THE BUG AND UNTIL IT CAN BE VERIFIED NOTHING WILL BE FIXED.

Again, if the Message Pane is enabled by pressing F8 the email contents appear on the bottom and the email status goes from Unread to Read which is exactly what is not wanted. That action is the same as opening the email, not previewing the contents. Who is yelling now?

So, you did have the Message Pane hidden, which I didn't see mentioned in any of your other comments, but haven't set Thunderbird to mark the message as read after say 10 seconds or a reasonable amount of time in the Reading and Display section of General preferences.

I can get a print preview using Thunderbird 78.14.0 with the Message Pane hidden and using the Print Preview menu item, and can confirm it is blank in 91.1.0, 94.0b2 and 95.0a1 with the Message Pane hidden.

The new Print dialog has changed things and not having any computer science degrees or coding experience, just a volunteer Thunderbird and bug tester, am not sure whether it can be fixed.

As Wayne suggested, links to the other complaints would be appreciated, and so would a description of your workaround.

See Also: → 1730183, 1731183

Looks like the ability to hide the Message Pane, select a message in the Thread Pane and select Print from anywhere has been changed in Daily 95.0a1 on Fedora Linux.

All 'Print` commands are now disabled, context menu, Menu bar File > Print and App menu > Print.

So no preview will appear at all without the Message Pane enabled on Linux. Not sure that I had unread messages selected there.

Just tested on Windows 10 with the Message Pane hidden, selected a message and tried all Print commands including Ctrl+P with Unread messages.

There I was able to get one preview with the "Welcome to Thunderbird" page, and the others were blank except for header and footer information.

I think this is a bug.

Flags: needinfo?(mkmelin+mozilla)

If it looks like a bug and acts like a bug it's a bug.

Hi Bob

if the Message Pane is enabled by pressing F8 the email contents appear on the bottom and the email status goes from Unread to Read which is exactly what is not wanted. That action is the same as opening the email, not previewing the contents.

Yes that is correct. Some people like to scan down the list using eg: arrow keys and do not want to open each one and do not want them marked as read. But you seem to misunderstand something - whether you realised it or not, in order to see the contents of an email in the 'Message Pane', tab or in a 'Print Preview', that email is opened.
The word 'Preview' in this context - 'Print Preview' does not mean view the contents of something you have not opened as that is not possible - it is a preview of what is to be printed.

In version 78*
Tested - Message Pane disabled - email new unread - right click select 'Print Preview' - window opens and only shows headers no content is shown as email is not opened.

Tested - Message Pane disabled - email new unread in thread Pane - right click and select 'Mark' > 'As read'
right click select 'Print Preview' - window opens and now shows contents of the email.
In this case the email was opened in the background to allow contents to be displayed in the Print Preview.

In version 91*:
Tested - Message Pane disabled - email new unread in Thread Pane - right click - 'Print' is disabled so cannot select.

Tested - Message Pane disabled - email new unread in thread Pane - right click and select 'Mark' > 'As read'
Right click again and the drop down now offers an enabled 'Print' - select Print and Print Preview opens showing an 'about:blank' window.
Note at this point I have not 'opened it' in Message Pane or Tab etc.
It would seem the 'Print' which opens 'Print Preview' is now enabled if emails is 'Marked as read' BUT no longer automatically opens the email as previous, so cannot display any contents.

If the 'Print' is enabled then you would expect it to be able to open the email so it can display the contents of the email.

But in reality, as the code has changed - just open the email and you can then get a 'Print Preview' of email.
Please do not think you were never opening the email because that is not and never was the case.
If previously you believed you were getting a 'preview' of an unopened email then you were mistaken.

I would say the 'Print Preview' is now more safe because it does not open an email just because it has been marked as read.

I see the bug as - that 'Print' should not be enabled just because of a 'mark as read' - if it cannot open the document then it should not be enabled. Otherwise the user thinks something is wrong.

If the message pane is not shown, we should disable printing.

Assignee: nobody → mkmelin+mozilla
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(mkmelin+mozilla)
Resolution: INVALID → ---
Summary: Thunderbird 91.2.0 Print Preview does NOT work displaying either Welcome to Thunderbird or blank screen. → when message pane is now shown, print context menu and shortcut can still be used but no proper document can be printed
Target Milestone: --- → 95 Branch
Status: REOPENED → ASSIGNED
Summary: when message pane is now shown, print context menu and shortcut can still be used but no proper document can be printed → when message pane is not shown, print context menu and shortcut can still be used but no proper document can be printed

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/7dd50ea46273
disable print if the message pane is not shown (F8). r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED

NOT resolved. By pressing F8 it brings up the message pane which displays the contents of the email, however, it then marks the email as Read.
That is the same as just opening an email which is NOT what a correct Preview should do. According to the 91.2.0 Release Notes if they would fix the New one-stop print dialog with integrated preview and settings so that when the Print option is selected it didn't display a preview of "Welcome to Thunderbird" or more frequently a Blank Screen, then the application would be functioning properly.

Bob says Note: The ability to Preview a suspect or any email without opening it was the single best feature in Thunderbird email.

This never existed. You seem to be completely misguided and believing something for a long time which was not true.

AS Magnus says:

Earlier the document was also opened, only in the background....There wouldn't have been any security advantages if that's what you were after.

What does that mean: Previously, if you right clicked on new unopened email and select 'Print Preview' - the email document was opened in the background in order to read the contents, so they could be shown in the 'Print Preview'.
The 'Print Preview' means seeing what you are about to print before you print it.
It does not mean get a look at something without opening the document to see what it contains. If you have been believing that was the case then you were mistaken. The only difference was the email in the list was not marked as read and the email document was opened in the background in order to extract contents.

Bob says - the message pane which displays the contents of the email, it then marks the email as Read. That is the same as just opening an email which is NOT what a correct Preview should do.

There is no such thing as a preview of an email without opening the email document to see contents. This has never existed. This has already been explained several times.

Currently, 'Print' is enabled if the Mark as Read option is selected either automatically or manually, but that does not mean the email is open, so the result is the preview of a Print is blank - it is blank because you have not selected to open the email and the new code means it is no longer opened; without your knowledge; in the background.

IF you want to open email, but do not want any automatic option to mark as read, then switch off that option so that you have full manual control over the 'Mark as Read'. You do that in the Preferences.
Menu app icon > Preferences > General - scroll down to the 'Reading & Display' section to see options.

After switching off the auto mark as read in Preferences:
Select email so it shows in the Message Pane
Right click and select 'Print' to see what you get when you print the email.

However, I cannot make this more clear - there is no need to use 'Print' to see a Print Preview just to read email contents and there never was any reason to open an email in Print Preview if no intention to Print.

Bob, you have helped to locate this bug which is good and helpful. We are very grateful to you bring this error to our attention.
The 'print' needs to be disabled if email is not open.

Query

The right click option does need to be available in the Thread Pane under certain conditions.

I may have previously opened and read and email, but now wish to print.
Right click on email in Thread Pane and select 'Print'
You should not need to open email again in order to Print.

Is there a way of setting a 'previously opened flag' which is not related to 'mark as read',
so allowing right click > Print to function correctly IF previously opened OR currently opened ?

Thoughts on this ?

(In reply to BOB from comment #22)

NOT resolved.

The fix is so far only for tb 95. We will eventually uplift it for 91.3 or so.

(In reply to Anje from comment #24)

You should not need to open email again in order to Print.

Unfortunately you do. We now print what we show, and if it's not showing we can't print it.

Comment on attachment 9245439 [details]
Bug 1735043 - disable print if the message pane is not shown (F8). r=darktrojan

[Approval Request Comment]
Regression caused by (bug #): not directly a regression. needed to to the 91 printing rework
User impact if declined: print is not properly disabled when message pane is not shown, can lead to confusion
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): very safe

Attachment #9245439 - Flags: approval-comm-esr91?
Attachment #9245439 - Flags: approval-comm-beta?

Comment on attachment 9245439 [details]
Bug 1735043 - disable print if the message pane is not shown (F8). r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9245439 - Flags: approval-comm-beta? → approval-comm-beta+

(In reply to Magnus Melin [:mkmelin] from comment #26)

(In reply to Anje from comment #24)

You should not need to open email again in order to Print.

Unfortunately you do. We now print what we show, and if it's not showing we can't print it.

OK understood.

Verified using 94.0b3 on Windows 10.

Status: RESOLVED → VERIFIED

I have Thunderbird 91.2.0 on Windows 10 what is 94.0b3?

Duplicate of this bug: 1726779

Comment on attachment 9245439 [details]
Bug 1735043 - disable print if the message pane is not shown (F8). r=darktrojan

[Triage Comment]
Approved for ers91 - thanks to on Walt's testing :) - so this will appear in 91.2.1 hopefully this week

I have Thunderbird 91.2.0 on Windows 10 what is 94.0b3?

that's beta

Attachment #9245439 - Flags: approval-comm-esr91? → approval-comm-esr91+

I just went from the frying pan TB ver 91.2.0 into the fire with TB ver 91.2.1
Now there is NO option to Print and Preview an Unopened email. Now you have to Open the email, which what I DO NOT want to do with suspect emails, and it will show you the contents and you have the option to print it which will display the contents that you already viewed! If you just wanted to View the contents without opening the email you are now screwed. I am certain this can't be what was intended by removing the Print Preview option from TB ver 75 when they went to TB ver 91.

Disabling the Print option is a quick fix that addresses the symptom rather than the problem -
I still need to be able to print messages from the inbox without using the preview pane.

(In reply to BOB from comment #36)

If you just wanted to View the contents without opening the email you are now screwed. I am certain this can't be what was intended by removing the Print Preview option from TB ver 75 when they went to TB ver 91.

I am at a loss because you continue to believe you were getting some additional safetly believing you were getting a 'preview' of an unopened email. This belief was incorrect.
The email document was always opened; it was opened in the background so you did not see it - so you never realised it had been opened. As it was not opened in the Message Pane it was never marked as opened.
So there is no difference except for the fact that you are now aware of it - I hope.
The 'Print preview' only showed a preview of what you were going to print, so you could check the layout. It was not and never was a preview of an unopened email document. There was no additional safety in seeing the layout preview of an email to be printed.

(In reply to david.slater from comment #37)

I still need to be able to print messages from the inbox without using the preview pane.

Are you saying you would like to click on Print and it goes directly to printing - after all you are clicking on 'Print' ?
If yes, that is a different issue.

This bug is about a right click 'Print' being enabled in drop down menu because 'mark as read' has occurred on that email.
It should not be enabled if the selected email is not actually open.
This means if not opened, but marked as read, the Print option returns a blank Print Preview.
The latest version ver 91.2.1 will fix.

Many thanks to those involved getting a rapid solution.

(In reply to Anje from comment #39)

(In reply to david.slater from comment #37)

I still need to be able to print messages from the inbox without using the preview pane.

Are you saying you would like to click on Print and it goes directly to printing - after all you are clicking on 'Print' ?
If yes, that is a different issue.

Assuming that there's no sarcasm here, I think Anje misunderstood David: He was not asking to print without seeing a print preview, but he was asking to be able to print a message from message list even when the Message Pane (which David calls message "preview pane") isn't shown. Hence he said that this bug (by disabling the print command entirely) is only fixing the symptom rather than the problem, which is true.

This bug is about a right click 'Print' being enabled in drop down menu because 'mark as read' has occurred on that email.

Sorry, but mark as read is not technically related to this bug in any way. In the current implementation, the message must be (selected and) displayed because when the new Firefox print dialog was ported, print has also been redesigned (simplified) on the Thunderbird side to print what's displayed in the message view (bug 1711408). Selecting the message may coincidentally cause Mark as read, but that behavior can be disabled in preferences, or the timeout can be changed.

Many thanks to those involved getting a rapid solution.

Well, it's not really solved, but just ironed over, and the inherent current resolution here is wontfix (per Bug 1727107 Comment 11).

It's unfortunate that reporter BOB was distracting from the main problem of this bug by insisting on his false view that printing without seeing the message in the Message Pane would have some security advantage, which is technically untrue, because any print preview (or direct print) will parse the entire message just as the message pane would (thanks for trying to get that through to Bob, Anje, but let's just ignore him from now on if he continues to dismiss that fact). So he wanted the right thing for the wrong reasons.

Nevertheless, comment 0 clearly expected the message to print even when the message pane is hidden, which is a legitimate expectation. This bug has now manifested the current unfortunate implementation. The net result is that users who prefer the message pane hidden can no longer print any message directly from the message list, which makes this bug an instance of ux-implementation-level: The behaviour is designed around the current implementation, which is detrimental wrt ux-efficiency. The current implementation is also unfortunate wrt ux-consistency, as Print is now the only command from the entire message context menu which is disabled when the message isn't displayed.

Regressed by: 1711408
See Also: 17301831727107, 1727865
Summary: when message pane is not shown, print context menu and shortcut can still be used but no proper document can be printed → when message pane is not shown, print context menu and shortcut can still be used but no proper document can be printed (wontfix: Print is now disabled if message pane is hidden)
Whiteboard: [wontfix per Bug 1727107 Comment 11]
  1. Why did TB versions prior to 91 contain a Print Preview option on the drop down list that so many users benefitted from even if it opened the message in the background as they say but left it marked as Unread?

  2. Version 91.2.0 Release Notes said the Print Preview option was now combined in the Print/Print Preview function on the drop down list, however,
    the only Preview that was displayed was either a Blank Screen or a Welcome to Thunderbird document.

  3. Now Version 91.2.1 there is no option to Print/Print Preview without first opening the email. This is a step backwards.

(In reply to BOB from comment #41)

Hey BOB, in case you've missed it, I've tried to ensure that this bug and related bugs are correctly understood, which includes pointing out the UX problems of the current implementation. Understanding the UX problems is key for trying to get them resolved. Please re-read my comment 40, because it has all the answers.
Whining won't help.

  1. Why did TB versions prior to 91 contain a Print Preview option on the drop down list that so many users benefitted from even if it opened the message in the background as they say but left it marked as Unread?

Answer:

when the new Firefox print dialog was ported, print has also been redesigned (simplified) on the Thunderbird side to print what's displayed in the message view (bug 1711408).

The new print dialog delivers substantial UX improvements, but unfortunately its current implementation (bug 1711408) also causes some significant print UX shortcomings/regressions (see See also list of bugs on this bug). That said, so far you're the only one who has associated this with leave message unread, which is odd for a number of reasons:

  • The delay before automatically marking messages read is fully under your control via preferences, and you can even switch the feature off.
  • The fact that right-click does not select the message is a bug (on Windows at least; I heard that MacOS has this behaviour in its file manager), not a feature.
  • I guess you are the only one who is trying to "preview" message contents using "print preview", due to your previous false assumptions about how print preview works. For all practical purposes, it's quite correct for previewing and printing to default to mark as read (but then, you can still change that in the Preferences if you don't like it).
  • It's really simple to mark a message as read or unread: Just press M to toggle the status.
  1. Version 91.2.0 Release Notes said the Print Preview option was now combined in the Print/Print Preview function on the drop down list, however, the only Preview that was displayed was either a Blank Screen or a Welcome to Thunderbird document.

I'm quite sure that we've explained to you before that in the current technical implementation (even though you and I are unhappy with that), we can only print what is displayed in the message pane (bug 1711408, told you!). So if your message pane displays Welcome to Thunderbird, that will be printed, and if it displays nothing, that will be printed, too. That was wrong as you were trying to print a message, and it has been "fixed" here by disabling Print for the scenarios where it fails. It's non-trivial to change the current implementation to print things which are not displayed, and hence it's currently WONTFIX per the decision of Magnus (:mkmelin), the technical manager, and Geoff (:darktrojan), leading developer, in Bug 1727107 Comment 11. So for now, please accept that you need to select and display a message for printing.

  1. Now Version 91.2.1 there is no option to Print/Print Preview without first opening the email. This is a step backwards.

Yes. We agree on that. The big step forward (having a much better, unified print dialog, and simplifying our printing code) came at a cost of some steps backwards. But you and I cannot change it right now unless if you are able to provide a patch. Fwiw, the much more significant fallout is bug 1727865.

(In reply to Thomas D. (:thomas8) from comment #42)

(In reply to BOB from comment #41)

Hey BOB, in case you've missed it, I've tried to ensure that this bug and related bugs are correctly understood, which includes pointing out the UX problems of the current implementation. Understanding the UX problems is key for trying to get them resolved. Please re-read my comment 40, because it has all the answers.
Whining won't help.

  1. Why did TB versions prior to 91 contain a Print Preview option on the drop down list that so many users benefitted from even if it opened the message in the background as they say but left it marked as Unread?

Answer:

when the new Firefox print dialog was ported, print has also been redesigned (simplified) on the Thunderbird side to print what's displayed in the message view (bug 1711408).

The new print dialog delivers substantial UX improvements, but unfortunately its current implementation (bug 1711408) also causes some significant print UX shortcomings/regressions (see See also list of bugs on this bug). That said, so far you're the only one who has associated this with leave message unread, which is odd for a number of reasons:

  • The delay before automatically marking messages read is fully under your control via preferences, and you can even switch the feature off.
  • The fact that right-click does not select the message is a bug (on Windows at least; I heard that MacOS has this behaviour in its file manager), not a feature.
  • I guess you are the only one who is trying to "preview" message contents using "print preview", due to your previous false assumptions about how print preview works. For all practical purposes, it's quite correct for previewing and printing to default to mark as read (but then, you can still change that in the Preferences if you don't like it).
  • It's really simple to mark a message as read or unread: Just press M to toggle the status.
  1. Version 91.2.0 Release Notes said the Print Preview option was now combined in the Print/Print Preview function on the drop down list, however, the only Preview that was displayed was either a Blank Screen or a Welcome to Thunderbird document.

I'm quite sure that we've explained to you before that in the current technical implementation (even though you and I are unhappy with that), we can only print what is displayed in the message pane (bug 1711408, told you!). So if your message pane displays Welcome to Thunderbird, that will be printed, and if it displays nothing, that will be printed, too. That was wrong as you were trying to print a message, and it has been "fixed" here by disabling Print for the scenarios where it fails. It's non-trivial to change the current implementation to print things which are not displayed, and hence it's currently WONTFIX per the decision of Magnus (:mkmelin), the technical manager, and Geoff (:darktrojan), leading developer, in Bug 1727107 Comment 11. So for now, please accept that you need to select and display a message for printing.

  1. Now Version 91.2.1 there is no option to Print/Print Preview without first opening the email. This is a step backwards.

Yes. We agree on that. The big step forward (having a much better, unified print dialog, and simplifying our printing code) came at a cost of some steps backwards. But you and I cannot change it right now unless if you are able to provide a patch. Fwiw, the much more significant fallout is bug 1727865.

(In reply to Thomas D. (:thomas8) from comment #40)

(In reply to Anje from comment #39)

(In reply to david.slater from comment #37)

I still need to be able to print messages from the inbox without using the preview pane.

Are you saying you would like to click on Print and it goes directly to printing - after all you are clicking on 'Print' ?
If yes, that is a different issue.

Assuming that there's no sarcasm here, I think Anje misunderstood David: He was not asking to print without seeing a print preview, but he was asking to be able to print a message from message list even when the Message Pane (which David calls message "preview pane") isn't shown. Hence he said that this bug (by disabling the print command entirely) is only fixing the symptom rather than the problem, which is true.

This bug is about a right click 'Print' being enabled in drop down menu because 'mark as read' has occurred on that email.

Sorry, but mark as read is not technically related to this bug in any way. In the current implementation, the message must be (selected and) displayed because when the new Firefox print dialog was ported, print has also been redesigned (simplified) on the Thunderbird side to print what's displayed in the message view (bug 1711408). Selecting the message may coincidentally cause Mark as read, but that behavior can be disabled in preferences, or the timeout can be changed.

Many thanks to those involved getting a rapid solution.

Well, it's not really solved, but just ironed over, and the inherent current resolution here is wontfix (per Bug 1727107 Comment 11).

It's unfortunate that reporter BOB was distracting from the main problem of this bug by insisting on his false view that printing without seeing the message in the Message Pane would have some security advantage, which is technically untrue, because any print preview (or direct print) will parse the entire message just as the message pane would (thanks for trying to get that through to Bob, Anje, but let's just ignore him from now on if he continues to dismiss that fact). So he wanted the right thing for the wrong reasons.

Nevertheless, comment 0 clearly expected the message to print even when the message pane is hidden, which is a legitimate expectation. This bug has now manifested the current unfortunate implementation. The net result is that users who prefer the message pane hidden can no longer print any message directly from the message list, which makes this bug an instance of ux-implementation-level: The behaviour is designed around the current implementation, which is detrimental wrt ux-efficiency. The current implementation is also unfortunate wrt ux-consistency, as Print is now the only command from the entire message context menu which is disabled when the message isn't displayed.

In my original Message I stated:

(In reply to Thomas D. (:thomas8) from comment #40)

(In reply to Anje from comment #39)

(In reply to david.slater from comment #37)

I still need to be able to print messages from the inbox without using the preview pane.

Are you saying you would like to click on Print and it goes directly to printing - after all you are clicking on 'Print' ?
If yes, that is a different issue.

Assuming that there's no sarcasm here, I think Anje misunderstood David: He was not asking to print without seeing a print preview, but he was asking to be able to print a message from message list even when the Message Pane (which David calls message "preview pane") isn't shown. Hence he said that this bug (by disabling the print command entirely) is only fixing the symptom rather than the problem, which is true.

This bug is about a right click 'Print' being enabled in drop down menu because 'mark as read' has occurred on that email.

Sorry, but mark as read is not technically related to this bug in any way. In the current implementation, the message must be (selected and) displayed because when the new Firefox print dialog was ported, print has also been redesigned (simplified) on the Thunderbird side to print what's displayed in the message view (bug 1711408). Selecting the message may coincidentally cause Mark as read, but that behavior can be disabled in preferences, or the timeout can be changed.

Many thanks to those involved getting a rapid solution.

Well, it's not really solved, but just ironed over, and the inherent current resolution here is wontfix (per Bug 1727107 Comment 11).

It's unfortunate that reporter BOB was distracting from the main problem of this bug by insisting on his false view that printing without seeing the message in the Message Pane would have some security advantage, which is technically untrue, because any print preview (or direct print) will parse the entire message just as the message pane would (thanks for trying to get that through to Bob, Anje, but let's just ignore him from now on if he continues to dismiss that fact). So he wanted the right thing for the wrong reasons.

Nevertheless, comment 0 clearly expected the message to print even when the message pane is hidden, which is a legitimate expectation. This bug has now manifested the current unfortunate implementation. The net result is that users who prefer the message pane hidden can no longer print any message directly from the message list, which makes this bug an instance of ux-implementation-level: The behaviour is designed around the current implementation, which is detrimental wrt ux-efficiency. The current implementation is also unfortunate wrt ux-consistency, as Print is now the only command from the entire message context menu which is disabled when the message isn't displayed.

In my original message I stated:
"I still need to be able to print messages from the inbox without using the preview pane."
I should have said "... message pane" apologies for any confusion.

(In reply to Thomas D. (:thomas8) from comment #40)

(In reply to Anje from comment #39)

(In reply to david.slater from comment #37)

I still need to be able to print messages from the inbox without using the preview pane.

Are you saying you would like to click on Print and it goes directly to printing - after all you are clicking on 'Print' ?
If yes, that is a different issue.

Assuming that there's no sarcasm here, I think Anje misunderstood David:

Correct - no sarcasm involved. As the Print function uses a 'Print Preview' window and the topic was discussing a blank preview window when the email is not shown in Message Pane, I assumed David's comment on 'preview' pane was the 'Print Preview'.

You need to log in before you can comment on or make changes to this bug.