Closed Bug 173519 Opened 20 years ago Closed 20 years ago

mozilla crashes each time attempting to print a mail message [@ nsPrintingPromptService::OnProgressChange]

Categories

(MailNews Core :: Printing, defect)

defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: johnip, Assigned: rods)

Details

(Keywords: crash, topcrash)

Crash Data

Attachments

(2 files)

Mozilla Version:-
1.2b (Mozilla/5.0 (X11; U; IRIX64 IP30; en-US; rv:1.2b)Gecko/20021009)

Build Date:-
October 9th 2002

Build ID:-
2002100900

Platform:-
SGI IP30 Octane Dual CPU 250Mhz R10000

OS:-
Irix 6.5.18m (Engineering Alpha)
uname -aR output - IRIX64 python 6.5-ALPHA-1278407620 6.5.18m 08051357 IP30

Mozilla Componant:-
Mail/News client

Description of problem:-
mozilla crashes (mozilla browser and mail/news client) each time attempting to
print a selected/viewed mail message.

To reproduce:
1) Open mail window from top menu
2) Select a mail message you wish to print
3) Select print from pull down menu OR use print icon
4) click on print button on the Print dialog box
5) A printing box appears and shortly after both the mozilla browser and
  the mail/news client dissapear from the screen

Printing from the mozilla browser works correctly and does NOT cause mozilla
to crash.

No core file is produced by the crash.
Severity: normal → critical
Keywords: crash
Confirmed, Linux/2002100911.

I get a crash at the very end of the printing process, when progress meter is
around/approacking 100%.
Status: UNCONFIRMED → NEW
Ever confirmed: true
-->
Assignee: dcone → rods
There was a problem that was checked in on Monday, but i see John's build is
from thurday. I will need a talkback or stack trace, something.
As said before, this looks like bug 172783 (already "fixed"). Since that was
marked a blocker, I do the same here. I see this with Mozilla/5.0 (X11; U; Linux
i686; en-US; rv:1.2b) Gecko/20021011 (complied from mozilla-source.tar.bz2
10/10/02 14:58:00). I am not able to produce crash data with this build, sorry.

pi
Severity: critical → blocker
OS: IRIX → All
Hardware: SGI → All
Attached file stacktrace
mWebProgressListener is NULL
Summary: mozilla crashes each time attempting to print a mail message → mozilla crashes each time attempting to print a mail message [@ nsPrintingPromptService::OnProgressChange]
Up to 10-07, there were crashes in talkback in
nsPrintingPromptService::OnStateChange.  Starting on 10-08 (when bug 172783 was
fixed), there have been crashes in nsPrintingPromptService::OnProgressChange.

(See http://www.people.fas.harvard.edu/~dbaron/mozilla/talkback10 )
Keywords: topcrash
We have the same problem in a Solaris 2.8 Sparc box.

Mozilla Version:

Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.2b) Gecko/2002XXXX

Where XXXX is since 2 weeks ago (aprox.)
Using dbx on the 10/14/2002 build I have managed to get a core file, I don't know
what use it will be since I did not have the source. Here's what dbx gave me
at the time of the SEGV :-

dbx version 7.3.2 73509_May21 MR May 21 2001 17:15:31
Process  5436 (mozilla-bin) stopped at [__poll:20 +0x8,0xfaf77e8]
         Source (of /xlv46/6.5.18m/work/irix/lib/libc/libc_n32_M4/sys/poll.s)
not available for Process  5436
(dbx) si
Process  5436 (mozilla-bin) stopped at [__poll:21 ,0xfaf77f0]
*[__poll:21, 0xfa523d4]         jr      ra
 [__poll:21, 0xfa523d8]         nop
(dbx)

Do you want the core file ?

Shall I do a CVS build of mozilla on Irix and see if I can get more info out
of dbx ?

John
Attached patch patch v1Splinter Review
Bah! Another fix that when in on Windows and not the other platforms! We just
need to simply check for a valid  pointer.
Comment on attachment 102805 [details] [diff] [review]
patch v1

sr=alecf
Attachment #102805 - Flags: superreview+
Comment on attachment 102805 [details] [diff] [review]
patch v1

r=dcone
Attachment #102805 - Flags: review+
fixed
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Keywords: nsbeta1+
verified, I saw the crash with the 10-10 trunk linux build and did not see the
crash with the 10-29 trunk linux build.  
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ nsPrintingPromptService::OnProgressChange]
You need to log in before you can comment on or make changes to this bug.