Closed Bug 1735388 Opened 3 months ago Closed 3 months ago

Keep the variant when changing colorways on about:welcome and upgrade spotlight

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
95 Branch
Iteration:
95.1 - Oct 4 - Oct 17
Tracking Status
firefox94 + verified
firefox95 --- verified

People

(Reporter: Mardak, Assigned: Mardak)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We can make the variant "sticky," e.g., if the user currently has Bold selected when switching to a different colorway that then shows Bold. Some complications with switching to Default as do we switch to Auto or a specific Light/Dark?

Ed, can you elaborate on the complications related to Default? Wouldn't we keep the "sticky" behavior throughout there as well? Meaning Bold = Dark for Default, Soft = Light for Default, Balanced = Auto for Default?

The ordering of variants is Soft / Balanced / Bold and Auto / Light / Dark. The selected item should change from the first item to the second item when going from Default to a colorway? Do we change the order to be Light / Auto / Dark -- if so, do we still pre-select Auto for about:welcome, which then results in Balanced selected with this change?

Priority: -- → P1

Yes. I think we change the order on the Default theme to be "Light/Auto/Dark". So the sticky behavior from color to default would be:
Soft > Light
Balanced > Dark
Bold > Dark (I know this breaks the pattern. Is this easy to do? If not we can accept Bold > Auto)

"Cheers" appears to be the only theme with "Balanced" falling into the "Dark" pattern. This seems to be the single case where the sticky pattern wouldn't be ideal...so I think that's an acceptable trade off. Let me know if this doesn't make sense to you.

To summarize:

  • change the order for Default: 1) Light 2) Auto 3) Dark
  • keep the variant position when switching themes: e.g., Balanced <-> Auto <-> Balanced
  • can split out about:welcome for later if that helps upgrade spotlight land/uplift

[Tracking Requested - why for this release]: Would like to add some polish for existing users who want to switch among darker themes without flashing back to light theme.

Assignee: nobody → edilee
Iteration: --- → 95.1 - Oct 4 - Oct 17

Rework theme and variant activation to make variants sticky. Reorder Default to show Light then Auto so that Light and Soft are the same index. Also select the initial index based on current dark or light theme. Add transitions for variation children.

Attachment #9245790 - Attachment description: Bug 1735388 - Keep the variant when changing colorways on upgrade spotlight r?pdahiya → Bug 1735388 - Keep the variant when changing colorways on upgrade spotlight and about:welcome r?pdahiya
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e94a24b1bae8
Keep the variant when changing colorways on upgrade spotlight and about:welcome r=pdahiya
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

Comment on attachment 9245790 [details]
Bug 1735388 - Keep the variant when changing colorways on upgrade spotlight and about:welcome r?pdahiya

Beta/Release Uplift Approval Request

  • User impact if declined: Exploring dark colorways is difficult requiring double the clicks to keep switching back to Bold.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Open about:welcome and upgrade spotlight
  1. Go to colorway screen
  2. Change variant to Bold/Dark
  3. Switch colorway and still Bold/Dark
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Some javascript changes/simplifications to activate themes based on the previous selection instead of always assuming the first variant.
  • String changes made/needed: none
Attachment #9245790 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9245790 [details]
Bug 1735388 - Keep the variant when changing colorways on upgrade spotlight and about:welcome r?pdahiya

Approved for 94.0b6

Attachment #9245790 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Blocks: 1735385
Blocks: 1735389
QA Whiteboard: [qa-triaged]

I have verified that the theme variant remains the same while switching through different themes on both New Users Onboarding and Upgrade Users Onboarding using Firefox Nightly 95.0a1 (Build ID: 20211014212856) and Firefox Beta 94.0b6 (Build ID: 20211014201116) on Windows 10 x64, macOS 11.6, and Ubuntu Linux 20.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.