Open Bug 1735575 Opened 9 months ago Updated 8 months ago

Investigate adding aliases for ::-webkit-slider-*

Categories

(Core :: CSS Parsing and Computation, enhancement)

enhancement

Tracking

()

Webcompat Priority P3

People

(Reporter: denschub, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

In a recent WebCompat issue, I stumbled across a minor visual glitch caused by a site styling an <input type="range"> with ::-webkit-slider-runnable-track and ::webkit-slider-thumb, but not it's -moz-prefixed counterparts ::-moz-range-track and ::-moz-range-thumb.

I did not look into details, but it appears like the stylings could be fairly compatible to each other. That being said, this is lower on the priority-scale, as I don't recall frequent issues with this.

Summary: Investigate adding aliases for ::-webkit-slider → Investigate adding aliases for ::-webkit-slider-*

Do they really map one to one? We also have ::-moz-range-progress.

See also https://github.com/w3c/csswg-drafts/issues/4410

Flags: needinfo?(dschubert)

I guess they do map 1:1, it's just that -progress allows further customization

Some pseudo-elements do map, but others do not. I think saying that only aliasing some but not others will cause even more weirdness is fair, and given there is potential for an eventual spec resolution, this can also be a WONTFIX for now.

In cases where things are broken, we can also craft interventions that would probably address most of the issues, so we don't have a hard-dependency on engine support here.

I didn't find an existing issue for that, so I figured it's worth filing a new one. I marked this as webcompat-priority P3 because I'm not aware of any significant breakage caused by range input styling. Even if this gets closed as WONTFIX, we can always come back if we discover something critically broken.

Flags: needinfo?(dschubert)

It'd be interesting if you can give the patch a shot and see if it fixes the compat bug you were seeing out of curiosity :)

Flags: needinfo?(dschubert)

Sorry, took me a bit longer to get back to this.

Your patch fixes the compat issue on powerapps.com, it just looks like Chrome with this. I have not tested any other site, but I'm happy to run some tests internally if you'd be interested in that!

Flags: needinfo?(dschubert)
You need to log in before you can comment on or make changes to this bug.