Closed Bug 1735667 Opened 2 months ago Closed 2 months ago

delegatesFocus should also look for elements that are descendent of the slotted element

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox93 --- unaffected
firefox94 --- fixed
firefox95 --- fixed

People

(Reporter: sefeng, Assigned: sefeng)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

No description provided.
Assignee: nobody → sefeng
Status: NEW → ASSIGNED
Severity: -- → S3
Pushed by sefeng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e35a8f30c4f2
Make delegatesFocus to loop through descendents of slotted elements r=emilio
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/31285 for changes under testing/web-platform/tests
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

Comment on attachment 9245824 [details]
Bug 1735667 - Make delegatesFocus to loop through descendents of slotted elements r=smaug

Beta/Release Uplift Approval Request

  • User impact if declined: The <delegatesFocus> feature may work incorrectly under certain circumstances
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's not risky because this is just a bug fix for a dom feature.
  • String changes made/needed:
Attachment #9245824 - Flags: approval-mozilla-beta?
Upstream PR merged by moz-wptsync-bot

Comment on attachment 9245824 [details]
Bug 1735667 - Make delegatesFocus to loop through descendents of slotted elements r=smaug

Approved for 94.0b8.

Attachment #9245824 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.