Closed Bug 1736260 Opened 2 months ago Closed 2 months ago

DoH turned off - Firefox still using Cloudflare

Categories

(Firefox :: Preferences, defect, P2)

Firefox 93
defect

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox93 --- wontfix
firefox94 --- wontfix
firefox95 --- fixed

People

(Reporter: edwardp, Assigned: valentin)

References

Details

Attachments

(3 files)

Attached image about-networking.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:93.0) Gecko/20100101 Firefox/93.0

Steps to reproduce:

DoH is turned off in the Settings, yet on the about:networking page, it indicates it's using DoH via Cloudflare. Screenshots attached.

Actual results:

DoH remains on, despite settings showing it's off.

Expected results:

DoH should remain off, if setting show it's off.

Component: Untriaged → Preferences

The UI just shows the current TRR URI as parsed from the prefs. I'll add a different label to show the status of the TRR service (enabled/disabled)

Assignee: nobody → valentin.gosu
Severity: -- → S3
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2

Checked bug on Windows10 64bit and MacOs 11 and ubuntu 20.
using Firefox beta 94.0b7, release 93.0 and nightly 95
adding tracking flags.

Just having the TRR URI displayed in about:networking makes it confusing
to people expecting it to be empty when TRR is disabled.
This adds the TRR mode to the page.

Depends on D128888

Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/da505302e90f
Also show the TRR mode in about:networking r=nhnt11,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Duplicate of this bug: 1686797

I am now using a different Linux distribution which provides Firefox ESR, current version is 91.3.0esr.

I am seeing the same behavior in this release. The DoH box is unchecked, but about:networking is showing it's using Comcast's DoH service. Comcast is my ISP.

Is the fix also going to be included in the next ESR?

Thank you.

You need to log in before you can comment on or make changes to this bug.