Closed Bug 1736522 Opened 3 months ago Closed 3 months ago

Empty space for window control buttons in tab bar didn't go away after go full screen on mac

Categories

(Firefox :: Tabbed Browser, defect)

Firefox 95
x86_64
macOS
defect

Tracking

()

VERIFIED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox93 --- unaffected
firefox94 --- unaffected
firefox95 --- verified

People

(Reporter: mmis1000, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:95.0) Gecko/20100101 Firefox/95.0

Steps to reproduce:

  1. open a firefox in mac
  2. go full screen

Actual results:

There is weird empty space between the left most tab/tab scroll container and monitor edge

Expected results:

There is no weird empty space

Component: Untriaged → Tabbed Browser
OS: Unspecified → macOS
Hardware: Unspecified → x86_64

Hello
I can´t replicate this on my Mac 10.15 using Firefox release93 and I also tried nightly 95.

That empty area is where i have the close, minimize and maximize buttons.
I wonder why you don´t have those. Are you using a custom theme? You are using the latest nightly version 95 of firefox?

regards.

Flags: needinfo?(mmis1000)

(In reply to Pablo from comment #1)

Hello
I can´t replicate this on my Mac 10.15 using Firefox release93 and I also tried nightly 95.

That empty area is where i have the close, minimize and maximize buttons.
I wonder why you don´t have those. Are you using a custom theme? You are using the latest nightly version 95 of firefox?

regards.
It is not windowed, it is fullscreen with control preserved. So it won't has those. because those only shows on hover at monitor edge.

besides. No, it is not custom theme. This is a unconfigured empty profile I opened for debug only.

Flags: needinfo?(mmis1000)

oops. it seems i messed up the format a bit. i am typing theae on phone, and bugzilla on phone is a bit broken and hard to read. So I edd up type on the wrong line

Thank you!
I was able to replicate this on Mac0S 10.15 using Firefox nightly 95
Beta 94.0b8 and Release 93 are not affected.
Windows10 and Ubuntu 20 are not affected.

Steps:
Just launch firefox
click on the green circle to go to fullscreen mode

Mozregression:

Bug 1735318 - Unify "native" vs. "fullscreen" window controls. r=desktop-theme-reviewers,dao

build_url: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Mc--AU6uT1CKGoya6bQPEw/runs/0/artifacts/public%2Fbuild%2Ftarget.dmg
changeset: 837ba61b9975dda3559f6a1308d047331caca781
pushlog_url: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=1a071728a13b36aeda3b1c65f9ab3285e4299175&tochange=837ba61b9975dda3559f6a1308d047331caca781
repo_name: autoland

Severity: -- → S3
Keywords: regression
Regressed by: 1735318
Has Regression Range: --- → yes
Flags: needinfo?(emilio)
Assignee: nobody → emilio
Flags: needinfo?(emilio)

Set release status flags based on info from the regressing bug 1735318

Duplicate of this bug: 1735947
Status: UNCONFIRMED → NEW
Ever confirmed: true
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1145d08e7cd5
Hide titlebar button container on fullscreen on macOS. r=desktop-theme-reviewers,dao
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

Reproduced the issue with Firefox 95.0a1 (2021-10-19) on macOS 10.15.
The issue is no longer reproducible with Firefox 95.0b3 (20211104185958) on macOS 10.15. The empty space is no longer present.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.