Remove "rel=home" mapping to "Top" button in Links Toolbar

RESOLVED FIXED

Status

SeaMonkey
UI Design
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: Alon Altman, Assigned: Steve Chapel)

Tracking

({testcase})

Trunk
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

16 years ago
The HTML4.01 W3C recommendation defines "Start" for the first page in a
collection, not "First". Mozilla should support "Start" links instead of first,
per the W3C recommendation.

Comment 1

16 years ago
To XP Apps and adding Link Toolbar tracker.
Blocks: 103053
Component: DOM HTML → XP Apps
Blah. Time to find a computer with "diff" installed...
Assignee: jst → sgehani
QA Contact: stummala → paw
(Assignee)

Comment 3

16 years ago
Created attachment 102775 [details] [diff] [review]
Patch to change "First" to "Start" in the link navigation toolbar

This patch changes the text from "First" to "Start" and changes the entity
firstButton.label to startButton.label for consistency to avoid confusion. I
was reluctant to change the toolbarbutton id from link-first to link-start,
because it looks like that will have to be changed in every theme. Should I go
ahead and make that change, and change the Classic and Modern themes?
(Reporter)

Comment 4

16 years ago
The backend should be changed as well. Does the patch make mozilla react to
<LINK> entities with rel="start" as needed? The UI does not need to be changed.
(Assignee)

Comment 5

16 years ago
Created attachment 102802 [details]
Test case with <link rel="start">

The patch should make the Start button instead of the Top button active.
(Assignee)

Comment 6

16 years ago
Created attachment 102803 [details] [diff] [review]
Patch to make <link rel="start"> available through the Start button

This patch makes the link at <link rel="start"> available through the Start
button rather than the Top button.
Attachment #102775 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Keywords: patch, review, testcase
(Assignee)

Comment 7

16 years ago
It looks strange to see Start/Previous/Next/Last in the site navigation bar
because the opposite of "Start" is "End", not "Last". Should this bug be
extended to also change "Last" to "End"?
(Assignee)

Comment 8

16 years ago
Created attachment 102920 [details] [diff] [review]
Changes First/Last to Start/End and fixes <link rel=start>

This patch fixes the problem with Start/Last by changing Last to End.
Attachment #102803 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #102920 - Flags: review?(sgehani)

Comment 9

16 years ago
-> Steve

Steve, 
You might want to seek the review of the original authors of the links toolbar.
Assignee: sgehani → stevechapel
(Assignee)

Updated

15 years ago
Attachment #102920 - Flags: review?(sgehani) → review?(choess)
Comment on attachment 102920 [details] [diff] [review]
Changes First/Last to Start/End and fixes <link rel=start>

Steve: I'm sorry to intervene at this stage in the game, but this is not a good
change. To assemble the link toolbar, we used a number of specifications of
varying vintage, as well as HTML 4.01 (HTML 3.2 and an old Internet Draft on
link types, for instance), because they're richer and cover some aspects of
current practice that HTML 4.01 alone doesn't. From reconciling the various
specs, it seems that:
"begin" and "first" mean the beginning of a linear sequence. "top" and "origin"
mean the top of a hierarchical tree. "start" is rather vague and could be the
beginning of a sequence or the top of the tree. Since "tree-like" structures
are much more common in actual practice, I'd prefer to keep "start" under the
button now labeled "Top". If you feel like relabeling that "Start", I would be
willing to review, but please leave "first" and "last" as they are. (I'd also
appreciate it if you'd drop "home" out of the list of values for that button;
the one spec we have that mentions rel=home says it's reserved for
browser-internal use to correspond to the user's home page.) I apologize for
not carefully examining this before--I really should be working on a unified
spec for these (which hopefully can make XHTML 2).
Attachment #102920 - Flags: review?(choess) → review-
(Assignee)

Comment 11

15 years ago
Created attachment 107666 [details]
Test case with <link rel="home">

Testcase to ensure rel=home is no longer mapped to the Top button.
(Assignee)

Comment 12

15 years ago
Created attachment 107667 [details] [diff] [review]
Patch to remove mapping of rel=home to Top button

Here's a patch that just removes "home".
Attachment #102920 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Attachment #107667 - Flags: review?(choess)
(Assignee)

Updated

15 years ago
Attachment #102802 - Attachment is obsolete: true
Comment on attachment 107667 [details] [diff] [review]
Patch to remove mapping of rel=home to Top button

r=choess. Thanks, Steve!
Attachment #107667 - Flags: review?(choess) → review+
(Assignee)

Updated

15 years ago
Attachment #107667 - Flags: superreview?

Updated

15 years ago
Attachment #107667 - Flags: superreview? → superreview?(alecf)

Comment 14

15 years ago
Comment on attachment 107667 [details] [diff] [review]
Patch to remove mapping of rel=home to Top button

r=alecf
Attachment #107667 - Flags: superreview?(alecf) → superreview+
Summary: Site navigation bar should use "Start" instead of "First" → Remove "rel=home" mapping to "Top" button in Links Toolbar
(Assignee)

Comment 15

15 years ago
Could someone check this in for me? I don't have cvs access.
this has been checked in:

04/07/2003 17:01	timeless%mozdev.org 	mozilla/ xpfe/ browser/ resources/
content/ linkToolbarHandler.js 	1.6 	0/1  	Bug 173674 Remove "rel=home" mapping
to "Top" button in Links Toolbar
patch by stevechapel@earthlink.net r=stevechapel@earthlink.net sr=alecf

should it be marked fixed?
Yep, FIXED.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
*** Bug 201979 has been marked as a duplicate of this bug. ***
How is this fixed?  We removed rel="home" from the "Top" button, but the
_original_ issue here (what to do with rel="start") is not at all resolved.

Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 20

15 years ago
> How is this fixed? ... [T]he _original_ issue here ... is not at all resolved.

First read comment #10. Then if you think there's a way we can improve the
labelling of the buttons in the link toolbar or how we map rel attributes to the
buttons, I'm certainly willing to discuss it and make more testcases and patches.
Steve, I did read comment 10.  Multiple times.  Twice while the bug was still
open, twice more before I reopened it.

Chris manages to say nothing useful about "start" other than "oh, do something
with it".  This report, as filed, is still open.  So we can either address it,
mark this wontfix, or call this bug "mutated", reopen bug 201979, and move the
"start" discussion there, all over again.
(Reporter)

Comment 22

15 years ago
Marking FIXED per comment 21, discussion on START will pass to bug 201979.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.