money.cnn.com - extremely bad performance

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Boris 'pi' Piwinger, Unassigned)

Tracking

({perf})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021002

When going to $URL, say from http://piology.org/YASEP.html, it makes Mozilla
unresponsive for some seconds. Going back has the same effect. I have no clue
what the reason is (so this component, sorry). It is perfectly reproducible and
has been happening for a very long time, I just never reported it. I cannot find
a dupe.

pi
(Reporter)

Updated

16 years ago
Blocks: 118315
(Reporter)

Updated

16 years ago
Keywords: perf

Comment 1

16 years ago
it is unresponsive before/during/after it loads?
I got about 1/2 second pause after it had loaded, linux trunk build 20021009
450 MHz P-II

Comment 2

16 years ago
related: bug 167757 ?
seems to wfm anyway using Phoenix 20021007 on Win2k, could it be due to the
DHTML menu generation ?
(Reporter)

Comment 3

16 years ago
Andrew, I click the link, the page builds and looks finished (the progress bar
is not, though). Then for about three seconds (some pentium II style, I don't
know exactly) it does not do anything. Going back sometimes has the delay, but
shorter.

Olivier, I don't encounter the problem from bug 167757, don't know if related.

pi

Comment 4

16 years ago
ok, the fact that it happens (for you and me) after the page loads, I would
suspect that it's doing some javascript setup for menus or something.

You might try using Venkman to profile the page during load.

Comment 5

16 years ago
Created attachment 102536 [details]
profile from venkman

it says HM_f_StartIt used 3+ seconds, although my system certainly wasn't
unresponsive for that long.  Nothing really stands out as taking too much time.
(Reporter)

Comment 6

16 years ago
Created attachment 102554 [details]
venkman by pi (reporter)

OK, I don't understand what that means, but here is my data.

pi

Comment 7

16 years ago
the profile you got looks pretty similar to mine.  Basically, there doesn't
apear to be a big culprit that's doing something evil.  It appears to just be
intensive menu initialization.

Does the page load more quickly in other browsers (Opera/IE/Konq..)?  Did it
used to load more quickly in Mozilla?
(Reporter)

Comment 8

16 years ago
Created attachment 102662 [details]
profile from venkman (Win98SE)

Problem also happens with Windows.

pi
(Reporter)

Comment 9

16 years ago
OK, I tested on my Win98SE playstation;-)

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/2002101108 -> attached
Mozilla/4.79 [en] (Win98; U) much faster
Opera 6 much faster, but menus don't work
IE 6 first works, than for a shorter time than Mozilla not

So Mozilla is performing worst.

pi
OS: Linux → All
Hardware: PC → All

Updated

16 years ago
No longer blocks: 118315

Comment 10

16 years ago
using trunk build 2003041508 on winxp things are fine.
marking wfm?

Comment 11

16 years ago
I still see this with linux trunk 20030419.  Markus: I bet your computer is fast
enough to do the DHTML more quickly.

Boris: how fast is your computer?  (see comment 1)

Comment 12

16 years ago
Let's see what others say :)
Component: Browser-General → Layout
Cannot confirm this. Meaby because i have Athlon 18Ghz, but i dont see anything
special when moving between those two pages. Meaby it's related to Win98
architecture only?
(Reporter)

Comment 14

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030331

I still see this. AMD Athlon 800.

pi

Comment 15

15 years ago
->default contacts
Assignee: asa → other
QA Contact: asa → ian

Comment 16

15 years ago
WFM Gecko/20030917 Firebird/0.6.1+, Windows XP.

Comment 17

13 years ago
I can confirm this bug with Mozilla 1.7.5 on Windows XP on a 3GHz Pentium.

The work-around I use is to put the click in the URL and press Enter.  I need to
do this about 3-4 times, at which point the full page loads quickly.

Comment 18

13 years ago
I can confirm this bug with Mozilla 1.7.5 on Windows XP on a 3GHz Pentium.

The work-around I use is to click in the URL bar and press Enter.  I need to do
this about 3-4 times, at which point the full page loads quickly.

Comment 19

11 years ago
I think this bug has been fixed in Seamonkey 1.1.1.

Comment 20

10 years ago
Anyone still confirming this bug?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.