Menu of <option>s displays to the right of <select> location.

RESOLVED FIXED

Status

()

Core
Layout: Form Controls
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Shanta McBain, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
With Mozilla maximized drop list contents display a fixed distance to the right
of the list location. List to the right of center display off screen (I am
assuming that they display). This only accures in the maximized view. All other
window sizes seem to display properly. Also on testing this behavior I
discouvered that this is random. Once the browser gets it 'right' it seems to
remember from then on. in that session. Thought at first it may be the Java
script that I used for the top drop list but it is the same for the cgi.pm
crated list as well and is the same for all first views of any site with a list.

The tab bar makes a big diffrence if open things don't line up if closed they
do. The calculations for the location of the drop list seems to be based on the
entire window. changing the width of opening the side bar changes the location
of the drop list. Netscape 7 behaves the same. The calculations are for the
window when it first opens. Change the width of the side bar after the page has
opened and the drops list open in the original calculated positions.


I have been able to duplicate this in 
Mozilla nightly download
Mozilla 1.0
Netscape 7
I've never observed this problem in Mozilla 1.1.
Summary: Droplist display of to right of list location. → Menu of <option>s displays to the right of <select> location.

Comment 2

16 years ago
the problem with the sidebar is bug 53318.  maximizing the window works fine for
me with linux trunk build 20021010

Comment 3

16 years ago
I don't see this bug in Build 2002102308. It might have been fixed when teh fix
for bug 146108 landed. Reporter can you confirm that this bug is gone.
(Reporter)

Comment 4

16 years ago
The problem now has been fixed. todays getmoz it was a problem its seemed in
yesterdays. Thu Oct 24 2002. Thanks 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.