[LNX]Drop down boxes (<select>) not rendered correctly after sidebar resize

RESOLVED DUPLICATE of bug 146108

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED DUPLICATE of bug 146108
18 years ago
15 years ago

People

(Reporter: djoham, Assigned: rods (gone))

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.15-4mdk i686; en-US; m18) Gecko/20000919
BuildID:    2000091908

If you load a page that has a drop down box, resize the sidebar (in any fashon)
and then try to activate the drop down box, you will find that the contents of
the drop down box are rendered incorrectly. Oddly enough, the frame for the
combo box will be in the correct spot.

Reproducible: Always
Steps to Reproduce:
1.Open the sidebar
2.Go to any page on the net that has a drop down box
3.Resize the sidebar
4. Attempt to activate the drop down		

Actual Results:  You will see the frame of the drop down's contents rendered in
the correct place, but the actual contents of the drop down will be rendered in
the wrong spot.								

Expected Results:  I would expect that the drop downs would render correctly.							

This bug may be related to bug 39992 as it also relates to odd rendering of
combo boxes.

I've attached a screenshot to demonstrate what I'm seeing.
(Reporter)

Comment 1

18 years ago
Created attachment 15071 [details]
screenshot of problem
(Reporter)

Comment 2

18 years ago
Created attachment 15072 [details]
maybe this screenshot will work
(Reporter)

Comment 3

18 years ago
Created attachment 15073 [details]
testing something - sorry for the SPAM
(Reporter)

Comment 4

18 years ago
Hrmmm....

It looks like Mozilla is having problems with Form submissions. When the server
finally accepts the fact that I've entered in a description, Mozilla seems to
corrupt the screenshot file during the file upload process.

The screenshot from 23:47 was posted from NN4.73 and was successful in the upload.

Sorry again for the SPAM

Comment 5

18 years ago
Looks like bug 52013

Comment 6

18 years ago
Verified on Linux buld 2000091908.  This isn't a duplicate of bug 52013; in
bug 52013 an action on one form component causes some action/change in
another form componet.  You can get both this bug and bug 52013 working at
the same time, which is even stranger than either one alone.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

18 years ago
I see this. Cc'ing Don since slamm is no longer working here.

Comment 8

17 years ago
Reassigning 50 Sidebar bugs to Matt.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → matt

Comment 9

17 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay
*** Bug 71241 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

17 years ago
Still happening in Mozilla/Linux build 2001052411

Comment 12

17 years ago
*** Bug 67661 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
This is a HTML form control problem. You can even resize the window for this
problem to occur. I'll attach a testcase.
Assignee: matt → rods
Component: Sidebar → HTML Form Controls
QA Contact: sujay → madhur

Comment 14

17 years ago
Created attachment 40749 [details]
testcase

Comment 15

17 years ago
setting platform/os to all
OS: Linux → All
Hardware: PC → All

Comment 16

17 years ago
oops wrong bug
OS: All → Linux
Hardware: All → PC
Summary: Drop down boxes not rendered correctly after a sidebar resize → Drop down boxes not rendered correctly after sidebar resize

Comment 17

17 years ago
spam! sorry about that
*** Bug 94332 has been marked as a duplicate of this bug. ***
*** Bug 95079 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Summary: Drop down boxes not rendered correctly after sidebar resize → [LNX]Drop down boxes not rendered correctly after sidebar resize
(Assignee)

Comment 20

17 years ago
Whatever code is figure out the absolute position for the drop down it doesn't
seem to know the content window has changed positions

Comment 21

17 years ago
*** Bug 97524 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
can stiil see the bug on buildID: 2001-09-04-06trunk RedHat Linux 7.1

Comment 23

17 years ago
isn't bug 54466 a dup of this?

Comment 24

17 years ago
*** Bug 99753 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Priority: P3 → P1
Target Milestone: --- → Future
(Assignee)

Comment 25

16 years ago
*** Bug 54466 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Attachment #40749 - Attachment is obsolete: true
*** Bug 110670 has been marked as a duplicate of this bug. ***
*** Bug 111456 has been marked as a duplicate of this bug. ***
This also happens if the <select> is in an iframe and the iframe is moved via
the DOM (see testcase in bug 111456).
Summary: [LNX]Drop down boxes not rendered correctly after sidebar resize → [LNX]Drop down boxes (<select>) not rendered correctly after sidebar resize
*** Bug 116690 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Priority: P1 → P3

Comment 30

16 years ago
These 5 bugs:

bug#53318
bug#64902
bug#67661
bug#86909
bug#129782

all seem very similar to me. Are there any duplicates here? Or any useful
information from any of the others that may help any of them get fixed?

*** Bug 139953 has been marked as a duplicate of this bug. ***
*** Bug 141449 has been marked as a duplicate of this bug. ***

Comment 33

16 years ago
Bug#147806 is very similar, and has a patch
Blocks: 173957

Comment 34

15 years ago
The bug as stated in Comment 1 is now fixed since the fix for bug 146108 landed.
Marking this as dupe of bug 146108

*** This bug has been marked as a duplicate of 146108 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.