Closed Bug 1740517 Opened 3 months ago Closed 2 months ago

Don't restore form data when going back to a page with a no-store header with session history in the parent

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED FIXED
96 Branch
Fission Milestone Future
Tracking Status
firefox-esr91 --- unaffected
firefox95 --- wontfix
firefox96 --- fixed

People

(Reporter: peterv, Assigned: peterv)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(1 file)

No description provided.
Fission Milestone: --- → ?
Severity: -- → S3
Blocks: 1736121

Peter says this bug affects SHIP with or without Fission, but is not super important because no-store semantics are not well-defined.

Fission Milestone: ? → Future
Priority: -- → P3
Pushed by pvanderbeken@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6a6e91c8eeeb
Don't restore form data when going back to a page with a no-store header with session history in the parent. r=smaug

Backed out 4 changesets (Bug 1741132, Bug 1740516, Bug 1740517) for causing mochitest failures on test_bug1741132.html.
Backout link
Push with failures
Failure Log

Flags: needinfo?(peterv)
Pushed by pvanderbeken@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e656dd82e48a
Don't restore form data when going back to a page with a no-store header with session history in the parent. r=smaug
Pushed by pvanderbeken@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/10f8761d740d
Don't restore form data when going back to a page with a no-store header with session history in the parent. r=smaug
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch
Flags: needinfo?(peterv)
Regressions: 1744038
You need to log in before you can comment on or make changes to this bug.