Closed Bug 1740609 Opened 6 months ago Closed 5 months ago

Select menu closes automatically due to parent element hover style

Categories

(Core :: Layout: Form Controls, defect)

Firefox 94
defect

Tracking

()

RESOLVED DUPLICATE of bug 1590247
Tracking Status
firefox-esr91 --- wontfix
firefox94 --- wontfix
firefox95 --- fixed

People

(Reporter: dixonj16, Unassigned)

References

(Regression)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:94.0) Gecko/20100101 Firefox/94.0

Steps to reproduce:

Firefox: 94.0.1 (64 bit)
OS: macOS 11.6

If the SELECT is in a DIV that modifies the overflow on hover then the select will close immediately on click or arrow press. Occasionally the select menu will open.

https://jsfiddle.net/ek2f5zm8/1/

HTML and CSS to reproduce.

<div class="wrap">
<select name="cars" id="cars">
<option value="volvo">Volvo</option>
<option value="saab">Saab</option>
<option value="opel">Opel</option>
<option value="audi">Audi</option>
</select>
</div>

.wrap {
border: 1px dashed #000;
margin: 5rem;
padding: 1rem;
overflow: hidden;
}
.wrap:hover {
overflow-y: scroll
}
select {
float: left;
width: 100%;
}

Actual results:

Select menu behaves unpredictably, in most cases will not remain open to allow selection.

Expected results:

The select menu should remain open when clicked or activated with arrow keys.

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Layout: Form Controls
Ever confirmed: true
Product: Firefox → Core
Regressed by: 1253486
See Also: → 1740439

Set release status flags based on info from the regressing bug 1253486

The severity field is not set for this bug.
:mats, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(mats)

This particular instance was fixed in bug 1590247, though root cause is the "See also" bug.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(mats)
Resolution: --- → DUPLICATE
See Also: → 1440506
Duplicate of bug: 1590247
You need to log in before you can comment on or make changes to this bug.