floated elements in captions do not get mouse events.

RESOLVED DUPLICATE of bug 164313

Status

()

Core
Layout: Tables
--
major
RESOLVED DUPLICATE of bug 164313
16 years ago
16 years ago

People

(Reporter: Matevz Jekovec, Assigned: karnaze (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

If you click at rate article buttons, they don't work. In IE, buttons are shown
as ordanary hyperlinks and work normally.

Reproducible: Always

Steps to Reproduce:
1. Load the page
2. Try to click any of the buttons (grades) for the article.
Actual Results:  
Buttons don't respond at all.

Expected Results:  
They should work as ordanary hyperlinks.

Comment 1

16 years ago
confirming using Phoenix 20021010 on Win2k.
This is due to the display:table-caption on the div containing all the content...

I'm working on reducing the testcase.
Looks like floated elements in table captions just don't get mouse events
correctly (eg if you click on those links the eventTarget is the <body> for the
first link and the <table> for the second link -- in both cases the <a> or the
float or the display:table-caption element do not get the event -- try it in
Inspector!).
Assignee: asa → karnaze
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Browser-General → HTMLTables
Ever confirmed: true
OS: Windows 98 → All
QA Contact: asa → amar
Hardware: PC → All
Summary: buttons don't work, fine in IE → floated elements in captions do not get mouse events.

Comment 5

16 years ago
is bug 164313 related?

Comment 6

16 years ago
this can be pretty old bug 48861
Could be, yes... In this case the caption is not empty, however (though it can
think it is, of course)

Comment 8

16 years ago
the problem is that not only floated elements dont get events inside a caption,
this will be fixed in bug 164313

*** This bug has been marked as a duplicate of 164313 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.