Closed Bug 1742567 Opened 6 months ago Closed 6 months ago

Attachment (non) hover behavior leads to unreadability (white on white or blue on blue)

Categories

(Thunderbird :: Theme, defect)

defect

Tracking

(thunderbird_esr91 unaffected, thunderbird95 unaffected)

RESOLVED FIXED
96 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird95 --- unaffected

People

(Reporter: newsfan, Assigned: Paenglab)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.45 Safari/537.36

Steps to reproduce:

As mentioned in bug 1667652 comment #22:
"Link" attachment (external or detached): Background goes blue if selected attachment is not hovered --> blue on blue.
Normal attachment: Background goes white if selected attachment is hovered --> white on white.

Works OK in TB 95 beta, so it must be a recent regression.

The hover issue is Windows only and a regression after bug 1740652.

The focus selected text colour of the detached attachment issue is on all platforms.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9252144 - Flags: review?(alessandro)
Regressed by: 1740652
Comment on attachment 9252144 [details] [diff] [review]
1742567-attachmentItem-colors.patch

Review of attachment 9252144 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks for taking care of this.
Attachment #9252144 - Flags: review?(alessandro) → review+
Target Milestone: --- → 96 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/dbc4bcfe93c2
Set the correct attachmentItem colors on hover/selected. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.