Table too wide (table width not enforced when all cell width are specified but cell content > specified width)

RESOLVED DUPLICATE of bug 95067

Status

()

Core
Layout: Tables
P4
normal
RESOLVED DUPLICATE of bug 95067
16 years ago
14 years ago

People

(Reporter: Max Alekseyev, Unassigned)

Tracking

({qawanted})

Trunk
Future
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

34.98 KB, image/gif
Details
553 bytes, text/html; charset=utf-8
Details
(Reporter)

Description

16 years ago
Not sure who is guilty but on the provided URL text overlaps with banner at right.
(Reporter)

Comment 1

16 years ago
Created attachment 102760 [details]
screenshot
Looks like another floater issue with tables...
Whiteboard: DUPEME

Comment 3

16 years ago
I think this is bug 52916.

Comment 4

15 years ago
no, this has nothing to do w/ floater.
The table is 720px wide (col width: 120px,427px,171px, total 718px )
The skyscraper ad is absolutely positioned at (x:722,y:0)

It seems the left column is too wide
Summary: Text overlaps with banner → Table too wide

Comment 5

15 years ago
this line: <tr><td align=right width=105><a href="/press/" ...
           <b>&#1055;&#1088;&#1077;&#1089;&#1089;-&#1082;&#1086;&#1085;&#1092;&#1077;&#1088;&#1077;&#1085;&#1094;&#1080;&#1080;</b></a></td>

The left column has the correct width initially, but it then reflows to
accomondate the long text (and whole table widens as result). The code
specifies the overall table width and cell widths, and I guess cell
width takes precendence over table width

from what I see in other bugs, Mozilla always overflow content
outside of fix-sized cell container but does not resize the container.
Why does Mozilla resize the cell in this instance?
Summary: Table too wide → Table too wide (table width not enforced when all cell width are specified but cell content > specified width)
Whiteboard: DUPEME
->Tables
Assignee: attinasi → table
Component: Layout → Layout: Tables
QA Contact: petersen → madhur

Comment 7

15 years ago
I do not see this behaviour on the Linux platform.
But, I do see the right banner overlaping the text in it's left column on winXP
and MacosX with 03-31-2003  trunk builds.

Comment 8

15 years ago
confirming bug 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4

Updated

15 years ago
Target Milestone: --- → Future

Comment 9

14 years ago
wfm winxp 2004090507
(Reporter)

Comment 10

14 years ago
Still see the bug with Mozilla Linux build 2004090707
Now the text and the banner still overlap, though the text under the banner is
not seen.

Comment 11

14 years ago
then we need a reduced testcase here
Keywords: qawanted

Comment 12

14 years ago
I dont't see any overlapping problems, but maybe the page has changed. Can
anyone upload a testcase?

Comment 13

14 years ago
Created attachment 163689 [details]
testcase

It's a line breaking issue. The table is set to a width of 720px, the left
column is set to a width of 120px. The ad on the right side is a div with
position:absolute; left:722px. 

The left column contains the following:
ИЗВЕСТИЯ-&nbsp;&nbsp;&nbsp;КАЗАХСТАН (Hope you can read it,
try setting the encoding to UTF-8). This doesn't fit in 120px; IE6 breaks after
"ИЗВЕСТИЯ-" but Mozilla expands the left column and thus the whole
table gets too wide. Basically, the summary of the bug says it all, the
specified width is not enforced.

Replacing any of the non-breaking spaces with an ordinary space fixes the
layout.

Comment 14

14 years ago
The issue is caused by the fact that the line doesn't break on the hyphen. (It's
the same if you just have normal chars or non-breaking spaces.)

*** This bug has been marked as a duplicate of 95067 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 15

14 years ago
*** Bug 201880 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.