Closed Bug 1746860 Opened 9 months ago Closed 9 months ago

FileLink: delete the file attached if is saved as drafts and send it

Categories

(MailNews Core :: Composition, defect)

defect

Tracking

(thunderbird_esr91+ fixed, thunderbird96 affected)

RESOLVED FIXED
97 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird96 --- affected

People

(Reporter: ediaz, Assigned: rnons)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:95.0) Gecko/20100101 Firefox/95.0

Steps to reproduce:

Steps to Reproduce the Problem

Attach a file using the Filelink for Plik: pluging
Save the email on drafts
Open the email and send the e-mail
Look for the original file on you disk (now it missing)

This ONLY happends when you create a Drafts email and save this Draft and send it from drafs.

Actual results:

Thunderbird delete the file on the original destination..

Expected results:

Thunderbird must keep the file on the original destination.

I report this to the original creator of the pluging and this is form Thunderbird not from the plugin..

https://gitlab.com/joendres/filelink-plik/-/issues/41

Version: Thunderbird 97 → Trunk
Assignee: nobody → remotenonsense
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: regression
Regressed by: 1710323

deserves a component also :)

Component: Untriaged → Composition
Product: Thunderbird → MailNews Core
Target Milestone: --- → 97 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/20ef33da1558
Do not remove tmp attachment sent via cloud. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

Comment on attachment 9256283 [details]
Bug 1746860 - Do not remove tmp attachment sent via cloud. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1710323
User impact if declined: File sent via cloud got removed from disk unexpectly
Testing completed (on c-c, etc.): beta
Risk to taking this patch (and alternatives if risky): low

Attachment #9256283 - Flags: approval-comm-esr91?

Comment on attachment 9256283 [details]
Bug 1746860 - Do not remove tmp attachment sent via cloud. r=mkmelin

[Triage Comment]
Approved for esr91

Attachment #9256283 - Flags: approval-comm-esr91? → approval-comm-esr91+
You need to log in before you can comment on or make changes to this bug.