Closed Bug 1747096 Opened 2 years ago Closed 2 years ago

No browser.search.region pref on Android

Categories

(Toolkit :: Form Autofill, defect)

Unspecified
Android
defect

Tracking

()

RESOLVED FIXED
97 Branch
Tracking Status
firefox97 --- fixed

People

(Reporter: serg, Assigned: serg)

References

Details

Attachments

(1 file)

This will affect our logic when we decide if credit card or address autofill will work on the device or not.

Severity: -- → S2

Currently, we cannot show credit card autofill in Fenix Nightly because browser.search.region is not set on Nightly and also confirmed on Beta. This automatically returns false when trying to determine whether or not autofill is supported since in https://searchfox.org/mozilla-central/rev/b605f01915c5704a55e9f485101b7be7d20a55df/toolkit/components/formautofill/FormAutofill.jsm#93. Regression caused from Bug 1745248.

I have confirmed that manually setting browser.search.region through about:config will fix the issue

  1. Go to about:config and confirm there’s no browser.search.region
  2. Add a credit card in the settings.
  3. Navigate to https://checkout.stripe.dev/preview
  4. Confirm no “Select credit card” dialog when selecting the card number input
  5. Add browser.search.region entry with US
  6. Close and restart Nightly
  7. Navigate to https://checkout.stripe.dev/preview
  8. Confirm “Select credit card” dialog shows when selecting the card number input
Assignee: nobody → sgalich
Attachment #9256566 - Attachment description: Bug 1747096 - No browser.search.region pref on Android r=gl!,dimi? → Bug 1747096 - No browser.search.region pref on Android r=gl!,dlee?
See Also: → 1747284
Pushed by sgalich@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4847e1cb0e48
No browser.search.region pref on Android r=gl,dlee?
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch
See Also: → 1760860
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: