Closed Bug 1747360 Opened 1 year ago Closed 11 months ago

[91.4.1] Attachments with extensions not registered in MIME type cannot be opened in Thunderbird Ver91.4.1

Categories

(Thunderbird :: Message Compose Window, defect)

Thunderbird 91
Unspecified
Windows
defect

Tracking

(thunderbird_esr91+ fixed, thunderbird97 fixed)

RESOLVED FIXED
98 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird97 --- fixed

People

(Reporter: runthekarion, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [regression: TB96])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.110 Safari/537.36

Steps to reproduce:

I can reproduce by following these steps:

  1. Start Thunderbird (Ver91.4.1) and click [Write]
  2. Attach and [save] the attachment (.cab)
  3. Double-click the attachment (.cab) saved from the draft

Actual results:

Actual results: No reaction (Ver91.4.1)

Expected results:

Expected results: File Picker is displayed (Ver91.4.0)

There is no problem with the extension registered as a MIME type.
.zip .pdf .xlsx .bmp .txt

Keywords: dupeme
Component: FileLink → Message Compose Window

Extensions that are not of MIME type now respond when you add the following registry

Example: (Refer to .zip)
HKEY_CLASSES_ROOT \ .cab
Content Type
REG_SZ
application / x-zip-compressed

xref/dupe of bug 1744259

Keywords: regression
See Also: → 1744259
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Attachments with extensions not registered in MIME type cannot be opened in Thunderbird Ver91.4.1 → [91.4.1] Attachments with extensions not registered in MIME type cannot be opened in Thunderbird Ver91.4.1

In 'View' > 'Message Source' (Ctrl+U)
is Attachment info :
Content-Type: application/octet-stream ?
If no what is Content Type ?

Flags: needinfo?(runthekarion)

(In reply to Anje from comment #4)

In 'View' > 'Message Source' (Ctrl+U)
is Attachment info :
Content-Type: application/octet-stream ?
If no what is Content Type ?

The Content-Type of the attached files is as follows:
Content-Type: application/octet-stream; name="38114c7c-0b7d-4061-9272-9edaf5545e3e.dmp"
Content-Type: application/octet-stream; name="DisplayAudiox64.cab

Double-clicking the same attachment in Thundebird 78.14.0 (and 91.4.0) opens a dialog, not in 91.4.1

(In reply to Anje from comment #4)

In 'View' > 'Message Source' (Ctrl+U)
is Attachment info :
Content-Type: application/octet-stream ?
If no what is Content Type ?

I'm sorry if it didn't get the response Anje was looking for
Comment 1 is not a workaround, it just started to respond when I tried to write MIME type information (.cab) in the registry.
I don't know what will happen to the registry operation, so please wait until it is resolved without referring to comment 1.

Flags: needinfo?(runthekarion)

Same for me here, I have version 91.4.1 and could not open simple .log text files. Quite annoying.

I used the workaround of Savior13 by adding the registry key "Content Type" with the value "text/plain" and it now works.
Hope this will get fixed in futur release !

Anyways, thanks for the amazing work guys !
Fuzl.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
OS: Unspecified → Windows

For some reason deep in the parser code, application/octet-stream attachments lose their content type.
This causes the new attachment opening code to throw an exception on Windows if nothing is registered for the attachment's extension.
If an exception is thrown here (for this reason or any other) fall back to the generic application/octet-stream type.

Depends on D135470

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/d34feb5081ce
Catch error opening attachment with an unknown content type. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 98 Branch

Comment on attachment 9258598 [details]
Bug 1747360 - Catch error opening attachment with an unknown content type. r=aleca

[Approval Request Comment]
Regression caused by (bug #): bug 1737711
User impact if declined: some attachments won't open on Windows
Testing completed (on c-c, etc.): landed last week
Risk to taking this patch (and alternatives if risky): low but not zero

Attachment #9258598 - Flags: approval-comm-esr91?
Attachment #9258598 - Flags: approval-comm-beta?

Comment on attachment 9258598 [details]
Bug 1747360 - Catch error opening attachment with an unknown content type. r=aleca

[Triage Comment]
Approved for beta

Attachment #9258598 - Flags: approval-comm-beta? → approval-comm-beta+

thank you. We have confirmed that this issue has been fixed in Thunderbird 97.0b2.
It doesn't seem to be fixed in Thunderbird 91.5.1 yet
I hope it will be fixed in a near future update.

(In reply to Savior13 from comment #15)

thank you. We have confirmed that this issue has been fixed in Thunderbird 97.0b2.
It doesn't seem to be fixed in Thunderbird 91.5.1 yet
I hope it will be fixed in a near future update.

With no side effects seen, like Bug 1751441 - attachments not opening properly TB 97.0b2 ?

Flags: needinfo?(runthekarion)
Keywords: dupeme

(In reply to Wayne Mery (:wsmwk) from comment #16)

(In reply to Savior13 from comment #15)

thank you. We have confirmed that this issue has been fixed in Thunderbird 97.0b2.
It doesn't seem to be fixed in Thunderbird 91.5.1 yet
I hope it will be fixed in a near future update.

With no side effects seen, like Bug 1751441 - attachments not opening properly TB 97.0b2 ?

I'm sorry. My confirmation was not good.
Certainly Ver97 beta2 now opens a dialog with a MIME type attachment that didn't respond when double-clicked.
This point has been improved.
However, it did not return as before (Ver91.4.0).
(See attached file DialogCompare.jpg)
There is no checkbox in the dialog and I can't specify which application to open in the future.
Therefore, the initial value of the radio button becomes "Save File" every time the attached file is opened by double-clicking.
Is it related to the fact that "which is" has changed from "Cabinet File" to "application / octet-stream"?

Flags: needinfo?(runthekarion)
Attached image DialogCompare.jpg

I have 91.5.1 and its not working.. its tragedy .
Is any portal where i can send this information as failer or defect?

(In reply to marcin from comment #19)

I have 91.5.1 and its not working.. its tragedy .
Is any portal where i can send this information as failer or defect?

I think 91.6.0 should release tomorrow. Could you report back if it works there or is still the same?

I have install 91.6.0 and defect with attachment *.dwg is still not repair

I have tried Thunderbird 91.6.0, but the issue reported by Savior13 has not been fixed. Double-clicking on a cab file does not respond at all.
Please reopen this bug.

(In reply to EarlgreyTea from comment #22)

I have tried Thunderbird 91.6.0, but the issue reported by Savior13 has not been fixed. Double-clicking on a cab file does not respond at all.
Please reopen this bug.

(no need to respond to this learning point)

A learning point ... please see the fields in the Tracking section at the top of this bug report:

  • Status = FIXED indicates the problem is fixed in the development (daily) branch. Target Milestone = 98 Branch indicates the first version that is fixed. This happened in comment 8. Note, FIXED does not mean this is fixed in the main public release.
  • thunderbirdnn tracking flag on the right indicates any beta branch that might have also gotten the patch. This happened in comment 10.
  • thunderbird_esr91 tracking flag on the right indicates the status of the version 91 branch. It is currently affected, meaning the patch has not yet reached that branch.

In short, it takes time for a "FIXED" patch to get into a release.

Regressed by: 1737711
Whiteboard: [regression: TB96]

Comment on attachment 9258598 [details]
Bug 1747360 - Catch error opening attachment with an unknown content type. r=aleca

[Triage Comment]
Approved for esr91

Attachment #9258598 - Flags: approval-comm-esr91? → approval-comm-esr91+

This didn't uplift to c-esr91 cleanly.

Flags: needinfo?(geoff)
Flags: needinfo?(geoff)
Attachment #9263830 - Flags: approval-comm-esr91+
Attachment #9258598 - Flags: approval-comm-esr91+
See Also: → 1751441
See Also: → 1753819
You need to log in before you can comment on or make changes to this bug.