Closed Bug 1747403 Opened 2 years ago Closed 2 years ago

Perma toolkit/components/featuregates/test/unit/test_FeatureGate.js | testAllDefaultsMatchSettings - [testAllDefaultsMatchSettings : 440] Feature devtools.webconsole.input.context should match runtime value. - fa when Gecko 97 merges to Beta on 2022-01-10

Categories

(Toolkit :: FeatureGate, defect)

defect

Tracking

()

VERIFIED FIXED
97 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox95 --- unaffected
firefox96 --- unaffected
firefox97 + verified

People

(Reporter: noriszfay, Assigned: aryx)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [retriggered])

Attachments

(1 file)

Central-as-beta simulation
How to run these simulations

Failure log:

[task 2021-12-23T12:50:28.153Z] 12:50:28     INFO -  TEST-START | toolkit/components/featuregates/test/unit/test_FeatureGate.js
[task 2021-12-23T12:50:28.418Z] 12:50:28  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/components/featuregates/test/unit/test_FeatureGate.js | xpcshell return code: 0
[task 2021-12-23T12:50:28.418Z] 12:50:28     INFO -  TEST-INFO took 264ms
[task 2021-12-23T12:50:28.418Z] 12:50:28     INFO -  >>>>>>>
[task 2021-12-23T12:50:28.419Z] 12:50:28     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2021-12-23T12:50:28.419Z] 12:50:28     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2021-12-23T12:50:28.419Z] 12:50:28     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2021-12-23T12:50:28.419Z] 12:50:28     INFO -  running event loop
[task 2021-12-23T12:50:28.419Z] 12:50:28     INFO -  toolkit/components/featuregates/test/unit/test_FeatureGate.js | Starting testReadAll
[task 2021-12-23T12:50:28.419Z] 12:50:28     INFO -  (xpcshell/head.js) | test testReadAll pending (2)
[task 2021-12-23T12:50:28.420Z] 12:50:28     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2021-12-23T12:50:28.420Z] 12:50:28     INFO -  TEST-PASS | toolkit/components/featuregates/test/unit/test_FeatureGate.js | testReadAll - [testReadAll : 83] Features are returned in order of definition - "test-featureA" == "test-featureA"
<...>
[task 2021-12-23T12:50:28.453Z] 12:50:28     INFO -  TEST-PASS | toolkit/components/featuregates/test/unit/test_FeatureGate.js | testAllDefaultsMatchSettings - [testAllDefaultsMatchSettings : 440] Feature devtools.inspector.compatibility.enabled should match runtime value. - false == false
[task 2021-12-23T12:50:28.453Z] 12:50:28  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/components/featuregates/test/unit/test_FeatureGate.js | testAllDefaultsMatchSettings - [testAllDefaultsMatchSettings : 440] Feature devtools.webconsole.input.context should match runtime value. - false == true
[task 2021-12-23T12:50:28.454Z] 12:50:28     INFO -  /opt/worker/tasks/task_164026289053942/build/tests/xpcshell/tests/toolkit/components/featuregates/test/unit/test_FeatureGate.js:testAllDefaultsMatchSettings:440
[task 2021-12-23T12:50:28.454Z] 12:50:28     INFO -  /opt/worker/tasks/task_164026289053942/build/tests/xpcshell/head.js:_do_main:240
[task 2021-12-23T12:50:28.454Z] 12:50:28     INFO -  /opt/worker/tasks/task_164026289053942/build/tests/xpcshell/head.js:_execute_test:604
[task 2021-12-23T12:50:28.454Z] 12:50:28     INFO -  -e:null:1
[task 2021-12-23T12:50:28.454Z] 12:50:28     INFO -  exiting test
[task 2021-12-23T12:50:28.454Z] 12:50:28     INFO -  Unexpected exception NS_ERROR_ABORT:
[task 2021-12-23T12:50:28.454Z] 12:50:28     INFO -  _abort_failed_test@/opt/worker/tasks/task_164026289053942/build/tests/xpcshell/head.js:875:20
[task 2021-12-23T12:50:28.455Z] 12:50:28     INFO -  do_report_result@/opt/worker/tasks/task_164026289053942/build/tests/xpcshell/head.js:976:5
[task 2021-12-23T12:50:28.455Z] 12:50:28     INFO -  Assert<@/opt/worker/tasks/task_164026289053942/build/tests/xpcshell/head.js:75:21
[task 2021-12-23T12:50:28.455Z] 12:50:28     INFO -  proto.report@resource://testing-common/Assert.jsm:228:10
[task 2021-12-23T12:50:28.455Z] 12:50:28     INFO -  equal@resource://testing-common/Assert.jsm:270:8
[task 2021-12-23T12:50:28.455Z] 12:50:28     INFO -  testAllDefaultsMatchSettings@/opt/worker/tasks/task_164026289053942/build/tests/xpcshell/tests/toolkit/components/featuregates/test/unit/test_FeatureGate.js:440:12
[task 2021-12-23T12:50:28.455Z] 12:50:28     INFO -  _do_main@/opt/worker/tasks/task_164026289053942/build/tests/xpcshell/head.js:240:6
[task 2021-12-23T12:50:28.455Z] 12:50:28     INFO -  _execute_test@/opt/worker/tasks/task_164026289053942/build/tests/xpcshell/head.js:604:5
[task 2021-12-23T12:50:28.456Z] 12:50:28     INFO -  @-e:1:1
[task 2021-12-23T12:50:28.456Z] 12:50:28     INFO -  exiting test
[task 2021-12-23T12:50:28.456Z] 12:50:28     INFO -  <<<<<<<
[task 2021-12-23T12:50:28.456Z] 12:50:28     INFO -  TEST-START | toolkit/components/url-classifier/tests/unit/test_listmanager.js

Hi Niklas, this seems to be related to bug 1742826 that was previously marked as fixed, which is caused by bug 1617609 , could you take a look please? Thank you!

Flags: needinfo?(ngogge)
[task 2021-12-23T12:50:28.453Z] 12:50:28  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/components/featuregates/test/unit/test_FeatureGate.js | testAllDefaultsMatchSettings - [testAllDefaultsMatchSettings : 440] Feature devtools.webconsole.input.context should match runtime value. - false == true

I don't think this is caused by the samesite prefs that we flipped. (Bug 1742826 covered all off those)

Hi Nicolas, you recently flipped the devtools.webconsole.input.context pref in https://phabricator.services.mozilla.com/D134482, i think this is related to that.

Flags: needinfo?(ngogge) → needinfo?(nchevobbe)
Regressed by: 1731740
No longer regressed by: samesitelax
Has Regression Range: --- → yes

Bug 1731740 set devtools.webconsole.input.context to true across all branches
and the separate, expected default value in FeatureGate still needed
adjustment.

Assignee: nobody → aryx.bugmail
Status: NEW → ASSIGNED
Whiteboard: [retriggered]
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/f1719c0c6dd1
adjust devtools.webconsole.input.context default value in FeatureGate. r=preferences-reviewers,Gijs
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch

Fix verified in today's central as early beta simulation.

Status: RESOLVED → VERIFIED

err, sorry about this and thanks for taking care of it!

Flags: needinfo?(nchevobbe)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: