Closed Bug 1748487 Opened 4 months ago Closed 4 months ago

Loss of display in Preferences > General when changing 'Show only display name for people in my address book'

Categories

(Thunderbird :: Preferences, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91+ fixed)

RESOLVED FIXED
97 Branch
Tracking Status
thunderbird_esr91 + fixed

People

(Reporter: anjeyelf, Assigned: mkmelin)

Details

Attachments

(1 file)

Windows 10 OS
Thunderbird: 91.4.1
Menu app icon > 'Preferences'
Select 'General'
Scroll down to 'Reading & Display'
'Display Name' sub section
Either select or uncheck: 'Show only display name for people in my address book'
That 'Preferences' tab either turns to a complete white or black background (depending upon dark or light theme) and no content is visible.

You need to close the 'Preferences' tab and then open it again to see content.
Note: what ever you selected is actually selected, so in that repect the preference was set.

This has been tested with same results in both Light and Dark theme and in 'Safe Mode/Troubleshooting Mode'.

This only happens when a message is selected. With no message selected or the server selected changing the pref works.

When it happens I get this error in msgMail3PaneWindow.js:418:
Uncaught Exception { name: "NS_ERROR_UNEXPECTED", message: "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getIntPref]", result: 2147549183, filename: "chrome://messenger/content/msgMail3PaneWindow.js", lineNumber: 418, columnNumber: 0, data: null, stack: "observe@chrome://messenger/content/msgMail3PaneWindow.js:418:52\nset valueFromPreferences@chrome://global/content/preferencesBindings.js:634:26\nset value@chrome://global/content/preferencesBindings.js:535:11\nuserChangedValue@chrome://global/content/preferencesBindings.js:210:11\nonCommand@chrome://global/content/preferencesBindings.js:233:12\nhandleEvent@chrome://global/content/preferencesBindings.js:284:23\n", location: XPCWrappedNative_NoHelper }
observe chrome://messenger/content/msgMail3PaneWindow.js:418
set valueFromPreferences chrome://global/content/preferencesBindings.js:634
set value chrome://global/content/preferencesBindings.js:535
userChangedValue chrome://global/content/preferencesBindings.js:210
onCommand chrome://global/content/preferencesBindings.js:233
handleEvent chrome://global/content/preferencesBindings.js:284

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/64ff1c8a6ad0
use default mail.displayname.version value of 0, get the right browser for ReloadMessage(), avoiding breakage when setting 'Show only display name for people in my address book'. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch

The change doesn't work: https://hg.mozilla.org/comm-central/rev/64ff1c8a6ad0#l2.24 - You need to use ++version.

Flags: needinfo?(mkmelin+mozilla)

Doh, will fix.

Flags: needinfo?(mkmelin+mozilla)
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/b1f56735227c
followup - properly adjust mail.displayname.version. r=me

Comment on attachment 9257624 [details]
Bug 1748487 - use default mail.displayname.version value of 0, avoiding breakage when setting 'Show only display name for people in my address book'. r=Paenglab

[Approval Request Comment]
Regression caused by (bug #): unknown
User impact if declined: blank prefs
Testing completed (on c-c, etc.): beta
Risk to taking this patch (and alternatives if risky): low risk

Attachment #9257624 - Flags: approval-comm-esr91?

Comment on attachment 9257624 [details]
Bug 1748487 - use default mail.displayname.version value of 0, avoiding breakage when setting 'Show only display name for people in my address book'. r=Paenglab

[Triage Comment]
Approved for esr91

Attachment #9257624 - Flags: approval-comm-esr91? → approval-comm-esr91+
You need to log in before you can comment on or make changes to this bug.