Open Bug 1750085 Opened 9 months ago Updated 4 months ago

Bad visual on Firefox start / restore. Dark rectangle

Categories

(Firefox :: Theme, defect)

Firefox 97
defect

Tracking

()

UNCONFIRMED

People

(Reporter: vqrhxw35a, Unassigned)

References

Details

Attachments

(2 files)

Attached image Firefox issue.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:97.0) Gecko/20100101 Firefox/97.0

Steps to reproduce:

I use Firefox dev to be automatically opened when Windows start.
The Firefox Window is opened not at full screen but to a lower size.
I use also a program called Min2Tray (that is free on the Internet) for minimize Firefox near the Windows time.

Often when I resume Firefox the browser show a blank window with a dark rectangle. For see correctly the content inside Firefox I need move the mouse on the Firefox Window bar

Actual results:

Often when I resume Firefox the browser show a blank window with a dark rectangle. For see correctly the content inside Firefox I need move the mouse on the Firefox Window bar

Expected results:

See correctly the webpage content. Firefox is showing as corrupted.

The Bugbug bot thinks this bug should belong to the 'Firefox::Theme' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Theme
Attached image GIF Firefox issue.gif

Thanks for reporting!
Has this issue only occurred recently?

Can you test the issue while in Safe Mode? You can find helpful info here: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode.
Further, a fresh new profile could help. You can find more about creating a new profile here: https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems#w_6-create-a-new-firefox-profile.

Flags: needinfo?(vqrhxw35a)

Hi and thanks for the answer.

Has this issue only occurred recently?

No, I have this issue since two different PC so is not short time, I just decide now to report as maybe no one is having this issue as for the use I do of the browser (not full Windows size, etc)

Can you test the issue while in Safe Mode?
Yes, I done this test in the past but I just repeated the test by restarting Firefox in Safe Mode where all extension is disabled than minimized with min2tray the browser, resumed and issue is still present.

Further, a fresh new profile could help.
Also this is not helping as I create new profile when I changed PC.

I don't know if this issue is generated in combination of Firefox and the Intel Graphic integrated driver.
The driver is updated.

Intel(R) UHD Graphics 630

Flags: needinfo?(vqrhxw35a)

The severity field is not set for this bug.
:dao, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dao+bmo)

Thanks for the reply, Marco!

I tried to reproduce this issue using Firefox 97 on Windows 10, my machine having the same Intel(R) UHD Graphics 630. I also used the Min2Tray application to minimize Firefox, but unfortunately I wasn't able to recreate the situation.

QA Whiteboard: QA-not-reproducible

Hi Ada,
I had this issue on two different PC.

One PC is already sold therefore no longer in my possession but one is my HP PC that I use every day also now.
HP Small Form Factor G7 HP Pro Desk 400

How can I help do diagnose and resolve this?
If I need give remote access to my PC I'm happy to try to help you.

I really wanna resolve this issue also because sometime happens also on currently stable version but this time opening the Firefox menu on the right. The menu show cutted.

Every time I resume my Firefox Window that is not full screen, I get this black issue, since long time.
I want really Mozilla to discovered what is causing this and fix.

Flags: needinfo?(ada.cristea)

Hi, Marco

Please see also Bug 1611056, this issue seems similar.

Flags: needinfo?(dao+bmo)
Flags: needinfo?(ada.cristea)
See Also: → 1611056

Hi Ada,
seems to be similar but I'm not sure.

I can confirm I'm on Windows 11 with Windows dark theme (the blue one)
The rectangle I see is not white but black and white, I see the video and seems similar but in my case never go out if I don't move the mouse on the address bar.

For me there is no flash issue, the issue is fixed and never goes out if I don't move the mouse on the browser address bar.
Seems a similar issue but not sure is the same.

Thanks for your precious help.

You need to log in before you can comment on or make changes to this bug.