Closed Bug 1750495 Opened 6 months ago Closed 5 months ago

Browser Action Popup is transparent.

Categories

(Thunderbird :: Add-Ons: Extensions API, defect)

Thunderbird 97
defect

Tracking

(thunderbird_esr91 unaffected, thunderbird97? fixed)

RESOLVED FIXED
98 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird97 ? fixed

People

(Reporter: TbSync, Assigned: TbSync)

Details

Attachments

(4 files)

Moz-Regression points to
https://phabricator.services.mozilla.com/D133958

But that looks unsuspicious to me.

Attached image actions.png

Hi. I'll attach a set of screenshot of this problem (using repro addon).

For detail description: I have confirmed this addon popup's transparent background issue on,

  • Thunderbird 97.0b1
  • 3 action types: browser_action compose_action message_display_action.

I wrote a sample demo addon as repro of this issue.

https://github.com/HiraokaHyperTools/ActionPopupTest

https://github.com/HiraokaHyperTools/ActionPopupTest/releases/download/v0.1/action_popup.xpi

Attached file action_popup.xpi

Testing on Daily with the test XPI I see that the panel gets a style="--arrowpanel-background: rgba(0, 0, 0, 0);". Disabling this style shows the normal background from the theme.

The root cause is that here:
https://searchfox.org/comm-central/rev/6bd44de06ffcfdd70c745ba757e966cf1f57ab08/mail/components/extensions/ExtensionPopups.jsm#181-185

someone is actually sending rgba(0,0,0,0) as background, instead of null, so somewhere defaults are injected.

Yes, porting https://hg.mozilla.org/releases/mozilla-beta/rev/85010d5acf5a#l1.12 and removing https://searchfox.org/comm-central/rev/ebb466e874faceafe7deeb9db812e426efae90f5/mail/components/extensions/ExtensionPopups.jsm#259 fixes it for me.

And adding <meta name="color-scheme" content="dark light"> in the <head> section of the test XPI makes it also follow the TB dark theme.

Assignee: nobody → john
Status: NEW → ASSIGNED

The theme-able popup feature is sure worth a topicbox post. That is nice.

Doing a try run before requesting check-in.
https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=904c46acb83cead97689c3f21f8f037a26c466bf

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/0f97c4e63350
Port relevant parts of bug 1744749 to fix transparent action popups. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 98 Branch

Comment on attachment 9259646 [details]
Bug 1750495 - Port relevant parts of bug 1744749 to fix transparent action popups. r=Paenglab

[Approval Request Comment]
Regression caused by (bug #):
Changes in M-C: Bug 1744749

User impact if declined:
Transparent action popus in beta 97

Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):
Low.

Attachment #9259646 - Flags: approval-comm-beta?

Comment on attachment 9259646 [details]
Bug 1750495 - Port relevant parts of bug 1744749 to fix transparent action popups. r=Paenglab

[Triage Comment]
Approved for 97.0b3.

Attachment #9259646 - Flags: approval-comm-beta? → approval-comm-beta+
Attached image fixed-on-TB97.0b3.png

Thank you, I have confirmed that the addon popup has background color, on Thunderbird 97.0b3!

You need to log in before you can comment on or make changes to this bug.