gtk theme dropdown (back/forward/print) doesn't follow GTK theme

RESOLVED DUPLICATE of bug 409655

Status

SeaMonkey
Themes
RESOLVED DUPLICATE of bug 409655
16 years ago
10 years ago

People

(Reporter: Paul McGarry, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

The dropdown button next to the back/forward/print button does not get themed
correctly with GTK theme.

Reproducible: Always

Steps to Reproduce:
1. Choose a GTK theme with noticable widgets (bumblebee is good)
2. Hover over the back/forward or print button
3. Note how the dropdown button (with the arrow on it) looks.
4. Compare to a native app (eg Galeon)
(Reporter)

Comment 1

16 years ago
Created attachment 103228 [details]
Mozilla 1.2b example
(Reporter)

Comment 2

16 years ago
Created attachment 103229 [details]
GTK dropdown example (from Galeon)
gtk theme bugs -> me
Assignee: shliang → bryner
Status: UNCONFIRMED → NEW

Updated

14 years ago
Blocks: 233462

Comment 4

14 years ago
maybe fixed.  need to retest.  sounds like a 1.8a task if still not working
Target Milestone: --- → mozilla1.8alpha
No, it's not fixed. The dropdown still looks different than other buttons, just
like on the first screenshot.
Created attachment 172789 [details]
Mozilla 1.8b/trunk 2005012802

This is yesterday's GTK2 build, GTK 2.x theme: Red Hat's Bluecurve Grape. The
dropdown button borders should look just like the "Search" button's ones, but
they don't.
Assignee: bryner → nobody
QA Contact: pmac → themes
Target Milestone: mozilla1.8alpha1 → ---
Marking as duplicate of 409665 rather than the other way around because there is a tad more developer-relevant material there.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 409655
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.