Closed Bug 409655 Opened 14 years ago Closed 3 years ago

[gtk2] Toolbar dropdown buttons should visually be two adjacent, independent buttons on GTK

Categories

(Core :: Widget: Gtk, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: fta+bugzilla, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image foward button
When hovered, the history (bottom arrow) part of the forward and backward buttons have no left corners.

Attached a screenshot, the bottom is missing but it's just a screenshot issue.
Just look at the top. This bug is about the red circle part.
Component: OS Integration → Widget: Gtk
Product: Firefox → Core
QA Contact: os.integration → gtk
Summary: [gtk2] foward/backward buttons → [gtk2] forward/backward buttons
** The following post is towards any developers who know more than I do about mozilla **
** So that's most developers **

I'm at least getting somewhere here, although I have one issue that isn't GTK related.

I have a box

+---------------------------------------+
| +--------------------------+ +------+ |
| |                          | |      | |
| |                          | |      | |
| |                          | |  __  | |
| |           A              | |  \/  | |
| |                          | |      | |
| |                          | |      | |
| |                          | |      | |
| +--------------------------+ +------+ |
+---------------------------------------+

Box A is the toolbutton containing the back/forward button, the box to the right is the xul:dropmarker button. They are both enclosed in another box which holds the state for the xul:dropmarker.

** Warning, I'm possibly about to misuse terms **
Both children are anonymous elements, so if I mouseover from one to the other, the state of the xul:dropmarker does not change.
Apparently using allowevents="true" fixes this, but it causes the xul:dropmarker to behave as the back button, no longer showing the dropdown.
So my question is... How do I make it so the xul:dropmarker causes state changes without using allowevents="true"?
In GTK such dual dropdown toolbar buttons seem not to be visually represented as a single object but rather as two adjacent buttons (tested in glade, since I didn't find any dualbutton in applications I had installed or quickly installable without using heaps of disk space).
We need to decide if we follow this style or not; twanno, ventnor, what do you think ?
Duplicate of this bug: 175095
This bug doesn't really apply anymore with the new unified look. Unless there is the possibility of reverting to the old style (either due to a rollback of the change or through options), I guess this should be closed.
My bad, sorry for the bugspam; before reading bug 175095, I didn't know there were other places where this kind of button was used. Maybe the description should be updated then, to reflect buttons with drop-downs as a whole.
Daniel: In fact, with the new unified look, on GTK they took the "two adjacent buttons" route, so my last question is answered. For other dropdown buttons, we could do the same.

I'm not sure I'll have time to write a patch for it, but if nobody does so soon, I'll try.
Summary: [gtk2] forward/backward buttons → [gtk2] Toolbar dropdown buttons should visually be two adjacent, independent buttons on GTK
Duplicate of this bug: 415438
Blocks: 415419
This should be now Thunderbird-only bug (not sure about Sunbird), since Firefox has merged the back and forward buttons.
_FrnchFrgg_: do not count on others. If you have ability to write a patch, just do it.
This should remain a Core bug as it applies to all products.
Ok. This bug is almost one year old... OMG.
No longer blocks: 415419
I take this bug. I'll be probably able to solve it next week or the week after; I think it's in fact really simple to solve, since we just need to remove the special casing for dropdowns and and modify some CSS.
Assignee: nobody → frnchfrgg
Status: NEW → ASSIGNED
Julien: any progress?
Blocks: 480935
Assignee: frnchfrgg → nobody
Status: ASSIGNED → NEW
Closing GTK2 related bugs since we removed GTK2 support at the beginning of 2018 in bug 1278282. Probably best to open a new bug in the unlikely event that any of these are still relevant.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.