Closed Bug 1752185 Opened 11 months ago Closed 10 months ago

Permafail browser_executionContext.js when Fission is enabled

Categories

(Remote Protocol :: CDP, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1586503

People

(Reporter: mccr8, Unassigned)

References

(Depends on 1 open bug)

Details

Bug 1750871 is going to change mochitest-remote to run with Fission enabled.

browser_executionContext.js fails when Fission is enabled, on at least Linux and OSX (it has already been disabled on OSX and Windows due to intermittent failures).

The failure is:

Received Runtime context events in expected order - ["Runtime.executionContextDestroyed","Runtime.executionContextsCleared","Runtime.executionContextCreated","Runtime.executionContextDestroyed"] deepEqual ["Runtime.executionContextDestroyed","Runtime.executionContextsCleared","Runtime.executionContextDestroyed","Runtime.executionContextCreated"]

It looks like executionContextDestroyed then executionContextCreated was expected at the end, but instead they were in the opposite order.

Depends on: 1586503
See Also: 1586503

Similar to other platforms we disabled the test on Linux. We will work on re-enabling it over on bug 1586503.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.