Open Bug 1755508 Opened 8 months ago Updated 4 months ago

Back not working

Categories

(Firefox :: Session Restore, defect)

Firefox 99
defect

Tracking

()

UNCONFIRMED

People

(Reporter: zlice555, Unassigned, NeedInfo)

Details

Attachments

(1 file)

Attached file about_support.txt

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:99.0) Gecko/20100101 Firefox/99.0

Steps to reproduce:

OS: Void Linux

  • Firefox open and used for hours
  • I left the house for a few hours
  • Came back (my PC was asleep, so I woke it up, but Firefox was still running and not closed)
  • I continued to use Firefox for a bit
  • I opened youtube, searched, click on a video (currently that window history should be - about:blank, youtube.com, some video)
  • I closed that window
  • A few seconds later a pressed Ctrl+Shift+N to open the recently closed window
  • Pressing back button or mouse back seems to 'refresh' the page and does not go back to youtube.com, but is stuck on the video

I don't think the "open closed window" has anything to do with this because I have had this happen for a while like this issue and my dupe. Sometimes a page refresh/F5 will allow back to work, sometimes not. Not sold on sleep mattering either but other issues I've seen mentioned they thought sleep may be involved.

Maybe something else to note? Most likely just extra info. When I open a new window I use my window manager's hotkeys, which runs firefox-bin, not Ctrl+N. Not sure if there's some weirdness in that.

Dont have the video I clicked on, but it has happened on multiple sites

Possible related bugs

my original - https://bugzilla.mozilla.org/show_bug.cgi?id=1728842

https://bugzilla.mozilla.org/show_bug.cgi?id=1729545

https://bugzilla.mozilla.org/show_bug.cgi?id=1729532

tldr - press back

Actual results:

page 'refreshes' (as if it is loaded instead of the actual previous page)

Reloading the page or pressing F5, or going forward and then back again MAY allow for back to work as expected

Expected results:

Page goes back to proper page in history.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Component: Widget: Gtk → DOM: Navigation

"I closed that window... A few seconds later a pressed Ctrl+Shift+N to open the recently closed window"
sounds like session restore.

Component: DOM: Navigation → Session Restore
Product: Core → Firefox

So "session restore" is a per window thing? I always considered that closing the browser and re-opening with everything you closed with.

Also, to note, this can happen on any window, closed or not. (Unless there are somehow 2 issues with the same symptoms)

Session restore is used also when reopening a closed window. It is like re-opening part of your session.

What do you mean with with comment 4?
Are the steps
"'I closed that window'
'A few seconds later a pressed Ctrl+Shift+N to open the recently closed window'"
no needed after all?

Sorry, just being thorough since I've seen this a few times. I do not believe it is. But I have no idea what causes it.

The severity field is not set for this bug.
:dao, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dao+bmo)

I haven't had this issue in a while now. Closing

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME

Spoke too soon. Started happening again today.

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.