New Feature Request: Fix TLD typos in entered URL

REOPENED
Unassigned

Status

SeaMonkey
Location Bar
--
enhancement
REOPENED
15 years ago
5 years ago

People

(Reporter: Jake Olefsky, Unassigned)

Tracking

(Blocks: 1 bug, {ux-error-prevention})

Trunk
ux-error-prevention

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016

I have clumbsy fingers.  Frequently when I am typing in a URL, I type '.con' or
'com' instead of '.com', but I press enter before I notice and then I get an
error.  I would be really nice if Mozilla could auto-correct certain common
typos. Mozilla could search for the typed in URL first, and if it cant connect
it could either pop up a window of suggested URLs, or if there is only 1
suggestion just go there.  

So, if I enter 'www.googlecom'. I would take me to 'www.google.com' once it
realized that I made a typo.  I'm sure I'm not the only person who does this.

Reproducible: Always

Steps to Reproduce:
1. Type "www.googlecom" into the URL area and hit enter.
2.
3.

Actual Results:  
An error pops up that says the website could not be found.  You have to click ok
before retyping your request.

Expected Results:  
Mozilla should recognize that "www.googlecom" is a typo and autocorrect it to
"www.google.com".
This feature request is already filed.... please search for the original bug and
mark this duplicate.
Whiteboard: DUPEME

Comment 2

15 years ago
Adding qawanted per comment 1.
Keywords: qawanted

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All

Updated

12 years ago
Keywords: qawanted
*** Bug 312096 has been marked as a duplicate of this bug. ***

Comment 4

11 years ago
I have written an extension to fulfill this feature request: http://efinke.com/url-fixer/ (and at https://addons.mozilla.org/firefox/2871/
 once it is approved.)  It will correct most typos that are related to the TLD (specifically .com, .net, .org, .edu, .gov, and .mil), and you can set it to confirm before making the correction or to just correct automatically.

Updated

11 years ago
Duplicate of this bug: 366226

Updated

11 years ago
Summary: New Feature Request: Fix typos in entered URL → New Feature Request: Fix TLD typos in entered URL

Updated

10 years ago
Duplicate of this bug: 428122
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
Assignee: hewitt → nobody
QA Contact: claudius → location-bar

Updated

9 years ago
Blocks: 479922

Comment 7

9 years ago
Does this include typos in the protocol? Sometimes I mis-highlight when copy-pasting a url and end up with "ttp://" in the address bar.

Comment 8

9 years ago
This or another bug should definitely cover mispellings of any variation of "http://" "www" and TLDs

Comment 9

6 years ago
Nowadays anything can be a TLD including .con .googlecom .xxx. WONTFIX
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Comment 10

6 years ago
Do you really think ICANN would allow someone to register .con for the purpose of typosquatting?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 11

5 years ago
As I understand, add-on from Comment 4 doing this job just fine, although it's address on AMO now https://addons.mozilla.org/en-US/firefox/addon/url-fixer/
I suppose, WONTFIX is valid resolution here then
Whiteboard: DUPEME → closeme WONTFIX 2012-08-01

Comment 12

5 years ago
Eh?  "An extension exists" is evidence in favor of a change, not a reason to reject it.
Keywords: ux-error-prevention
Whiteboard: closeme WONTFIX 2012-08-01

Comment 13

5 years ago
I'd say it's extension fodder myself.
You need to log in before you can comment on or make changes to this bug.