Closed Bug 1758340 Opened 11 months ago Closed 11 months ago

RTAMO onboarding page does not fetch the extension/theme name on Nightly

Categories

(Firefox :: Messaging System, defect, P1)

Firefox 99
defect

Tracking

()

VERIFIED FIXED
100 Branch
Iteration:
99.2 - Feb 21 - Mar 6
Tracking Status
firefox-esr91 --- unaffected
firefox98 --- unaffected
firefox99 + verified
firefox100 --- verified

People

(Reporter: acornestean, Assigned: mviar)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(7 files)

Affected versions:

  • Nightly (99.0a1/20220306190604)

[Steps to reproduce]:

  1. Access AMO Prod on a browser different from Firefox (example: Microsoft Edge) and afterwards the page of a recommended extension/theme.
  2. Click on the “Download Firefox and get the extension/theme” blue button
  3. A new page opens in the same tab and Firefox Release is automatically downloaded
  4. Install the previously downloaded Firefox Release.
    Note: After installation is complete, the browser will be automatically launched.
  5. Close the browser.
  6. Download and install the latest Nightly.
  7. Launch Nightly and access about:welcome.
  8. Observe that the RTAMO page loads, however the served add-on has it’s name replaced by a placeholder “{$addon-name}”.

[Expected results]:
The RTAMO about:welcome page should properly fetch the extension/theme name.

[Actual results]:
The RTAMO about:welcome page does not fetch the add-on name, instead it displays a placeholder - “{$addon-name}”.

For further details, see the attached screenshots.

NOTE:
I’ve also checked the latest Beta using the same STR as above and it’s not affected – the extension/theme names are properly fetched and displayed.

Attached image 2022-03-07_12h11_51.png
Attached image 2022-03-07_12h57_50.png

:mviar, since you are the author of the regressor, bug 1754069, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mviar)
Assignee: nobody → mviar
Status: NEW → ASSIGNED

A patch adding the missing prop is attached.

Flags: needinfo?(mviar)
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ffde799ecf4
RTAMO onboarding page does not fetch the extension/theme name on Nightly r=Mardak
Has Regression Range: --- → yes
Blocks: 1739252

[Tracking Requested - why for this release]: Needs to be uplifted as it impacts RTAMO flow in Fx99

Iteration: --- → 99.2 - Feb 21 - Mar 6
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch

Verified the fix to the RTAMO onboarding page on the latest Nightly (100.0a1/20220308220159) under Windows 10 x64 with both an extension and a theme.

The RTAMO about:welcome page now properly fetches the extension/theme name, confirming the fix.

For further details, see the attached screenshots.

Status: RESOLVED → VERIFIED
Attached image 2022-03-09_09h19_06.png
Attached image 2022-03-09_09h24_25.png

Are only nightly builds affected by this, or would you like to request a Beta Uplift?

Flags: needinfo?(mviar)

We'd like to request a beta uplift @dmeehan.

Flags: needinfo?(mviar)

Comment on attachment 9266793 [details]
Bug 1758340 - RTAMO onboarding page does not fetch the extension/theme name on Nightly

Beta/Release Uplift Approval Request

  • User impact if declined: Users would see “{$addon-name}” instead of the actual addon name on the return to AMO screen.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
  1. Access AMO Prod on a browser different from Firefox (example: Microsoft Edge) and afterwards the page of a recommended extension/theme.
  2. Click on the “Download Firefox and get the extension/theme” blue button
  3. A new page opens in the same tab and Firefox Release is automatically downloaded
  4. Install the previously downloaded Firefox Release.
    Note: After installation is complete, the browser will be automatically launched.
    Close the browser.
  5. Download and install the latest Nightly.
  6. Launch Nightly and access about:welcome.
  7. Observe that the RTAMO page loads, and the served add-on name is displayed
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One line fix (plus respective line in bundle) passing a missing prop to a component
  • String changes made/needed: no
Attachment #9266793 - Flags: approval-mozilla-beta?

Comment on attachment 9266793 [details]
Bug 1758340 - RTAMO onboarding page does not fetch the extension/theme name on Nightly

Approved for 99.0b2. Thanks.

Attachment #9266793 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified the fix to the RTAMO onboarding page on the latest Beta (99.0b2/20220310185912) under Windows 10 x64 with both an extension and a theme.

The RTAMO about:welcome page properly fetches the extension/theme name, confirming the fix.

For further details, see the attached screenshots.

Attached image 2022-03-11_09h22_27.png
Attached image 2022-03-11_09h26_54.png
You need to log in before you can comment on or make changes to this bug.