Allow multiple instances of Mozilla to run (with different profiles)

VERIFIED FIXED in mozilla1.3alpha

Status

Core Graveyard
Profile: BackEnd
VERIFIED FIXED
15 years ago
2 years ago

People

(Reporter: Steve Dagley, Assigned: Steve Dagley)

Tracking

Trunk
mozilla1.3alpha
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

3.54 KB, patch
Conrad Carlen (not reading bugmail)
: review+
Brian Ryner (not reading)
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

15 years ago
Now that we support locking of a profile there's no reason we should prevent
multiple instances of Mozilla from launching.
(Assignee)

Comment 1

15 years ago
Created attachment 103623 [details] [diff] [review]
Remove multiple instance check

Patch to remove the check
Comment on attachment 103623 [details] [diff] [review]
Remove multiple instance check

r=ccarlen
I take it you'll get rid of this resource:
::GetIndString(str, kNSCanRunStrArrayID, kAnotherVersionStrIndex
Attachment #103623 - Flags: review+

Comment 3

15 years ago
See also bug 175869.

Comment 4

15 years ago
Do we have per-profile locking in CFM that we know works?
Are there other non-profile files (e.g. Global.regs, Application Registry) that
don't use file locking, and need to if we allow the user to run several builds
at the same time?
(Assignee)

Comment 5

15 years ago
Simon suggested the following scenario and I tested it which reveals at least
one problem with the Application Registry when running multiple Mozilla builds:

1) launch Mozilla build A and select a profile
2) launch Mozilla build B and create a new profile
3) quit Mozilla build B
4) quit Mozilla build A
5) launch Mozilla (either build) and note that the profile created in step 2 is
not listed
True, but all other platforms would suffer the same problem and it's not been
reported as of yet. I'll file a bug on that since it's a separate (and XP) bug.
 But, since it's an obscure one, I don't think it should block this patch.

Comment 7

15 years ago
I too think that the failure case described here is rare, and hopefilly will not block others from enjoying this feature. let's pcommit the proposed patch.
(Assignee)

Updated

15 years ago
Target Milestone: --- → mozilla1.3alpha
Attachment #103623 - Flags: superreview+
(Assignee)

Comment 8

15 years ago
Checked in
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Component: Browser-General → Profile Manager BackEnd
QA Contact: asa → ktrina

Comment 9

15 years ago
So to launch mozilla a second time, the user just doubleclicks the mozilla icon
on his desktop? If not, how is it done?

Would be a pitty to have a feature that no-one knows how to use. ;)
(Assignee)

Comment 10

15 years ago
This is a feature targeted mainly at developers.  It doesn't mean you can have 2
copies of the same app binary running.  It means you can have Netscape 7.x or a
Mozilla release build running and also run a debug build you want to test
without quitting the other apps.

Updated

15 years ago
QA Contact: ktrina → gbush

Comment 11

15 years ago
verified running two builds of Buffy (3/12, 3/25)
Status: RESOLVED → VERIFIED
*** Bug 145127 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.