address book merge contact

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
16 years ago
a month ago

People

(Reporter: chris.pickett, Assigned: racham)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

Sometimes two different contacts are actually the same person and I would like
to merge them together.  One has a phone number, the other has an email address,
or both have different email address, etc. etc.  This would require some sort of
conflict resolution for the case where both contacts have a given field filled.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

16 years ago
What happens to RFE's?

Does anybody actually care?  Is their a database of RFE's somewhere?

Updated

14 years ago
Blocks: 259531

Comment 2

14 years ago
Reassign this bug to the module owner, otherwise I think this bug will languish
for a while longer...
Product: Browser → Seamonkey
Product is not intended to have artificial intelligence - how could it possibly
know what fields you would want to merge from two similar address cards, and
which card to merge them into.  Marking wontfix.

bug 222377 when delivered will get you 90% of what you want.
No longer blocks: 259531
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
*** Bug 259531 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

14 years ago
I was kind of annoying about it with comment 2 above (sorry) ... but ...

I didn't mean AI.

User selects any number of cards.  
Clicking on "merge" would create a brand new card. 
For any field that is present in only one of the cards, and is blank in all the
others, it gets automatically placed into the new card.
For conflicting email addresses, a list in the new card is created, and the user
is prompted to select which one is current / default.
For conflicts on other fields, the user is shown all of the old ones, and
prompted to edit the resulting field by hand.

Too tricky / obscure?  Bug 222377 doesn't really address the problem: I don't
want to lose information I've entered about my contacts, I want to preserve it
-- if it was a matter of simply deleting contacts I could do that even without
Bug 222377 (I don't use multiple address books), but as it is, I end up doing
merges by hand.

Updated

a month ago
Duplicate of this bug: 466584
You need to log in before you can comment on or make changes to this bug.