Source tarballs for releases should be made available

VERIFIED DUPLICATE of bug 170779

Status

()

VERIFIED DUPLICATE of bug 170779
16 years ago
11 years ago

People

(Reporter: joshe, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
A tarball of the source used to build phoenix releases should be made available
for download.  Building phoenix for other platforms would be made much easier if
a user could simply download a tarball, unpack it, and build.

If such tarballs are already available, then please call me an idiot and point
me towards them.
Dupe of bug 170779

Reporter, you can download a mozilla source tarball and make a "cvs update
browser and toolkit" from it. 
(Reporter)

Comment 2

16 years ago
ould I get the source to build phoenix 0.3 that way?  If so, what cvs tag should
I use?

This is not quite a dup of bug 170779, I'm not asking for nightly source, just
source for releases like 0.3, 0.4, etc.
Josh, the FAQ question 12 on the release-notes page answers your question:

12. Okay, so where's the phoenix source?
    cvs.mozilla.org. Mozilla trunk + mozilla/browser + mozilla/toolkit.

And yes, this is a dupe of bug 170779 because releases are only differently
labeled nightlies.

*** This bug has been marked as a duplicate of 170779 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
OK, well is there some way of fetching the source used for a particular release?
 Or should I just check out the source as of the release date and call it good
enough?
The last of your two mentioned options is the way to go.

Comment 6

16 years ago
IMO, this doesn't qualify as a dupe of bug 170779. I also have the same problem
as the reporter. I would like to install Phoenix-0.5 which would be relatively
stable as compared to the current CVS build. But there is no way to get the
source for Phoenix 0.5 (even via cvs). It would be good to have source tarballs
(including the mozilla source) for each release similar to the release tarballs
provided by mozilla.

Comment 7

16 years ago
This is not a duplicate of bug 170779. That bug talks about nightly tarballs.
This bug talks about tarballs named like phoenix-0.1.tar.bz2. Whether that is
just a symlink to the nighly tarball is irrelevant.

Any project, even those only interested in attracting developer quality users,
should have a tarball that allows users to do:

wget http://www.mozilla.org/.../phoenix-0.1.tar.bz2
tar -xvjf phoenix-0.1.tar.bz2 && cd phoenix-0.1
./configure && make && make install
cd .. && rm -rf phoenix-0.1

Why should they have such a tarball? Because even potential developers only go
to the work of doing a CVS checkout _after_ they've tried the latest release
and become interested in the project.

Comment 8

16 years ago
I'd like to add that users such as myself can't run the supplied binaries even if
we want to. The only platforms i have are i586-pc-linux and powerpc-unknown-linux.

Comment 9

16 years ago
v.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.