Bug 170779 (firefox_src_tarball)

Create nightly source tarballs for Aviary Products (Firefox / Thunderbird)

RESOLVED FIXED

Status

P3
enhancement
RESOLVED FIXED
17 years ago
5 years ago

People

(Reporter: roland.mainz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: waiting on buildbot+nightlies)

(Reporter)

Description

17 years ago
RFE: It would be nice to have nightly source tarballs for phoenix ...
(Reporter)

Updated

17 years ago
Alias: phoenix_src_tarball
(Reporter)

Comment 1

17 years ago
Over to leaf - the god of source tarballs... :)
Assignee: blaker → leaf

Comment 2

16 years ago
use CVS. we don't have the time or the resources for this at this stage. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
reopening to accept, setting a reasonable target milestone.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Target Milestone: --- → Phoenix0.4

Comment 4

16 years ago
(leaf, our milestones are happening about once every week to 10 days, not sure
if 0.4 is realistic for you knowing this). 
Status: REOPENED → NEW
(Reporter)

Comment 5

16 years ago
leaf:
Please correct me if I am wrong:
The current problem which "blocks" this bug is the issue that there is not
enougth disk space available, right ?

If "yes" - what about integrating the "phoenix"-parts with the standard
mozilla-source-*.tar.* source tarball for now ?

Comment 6

16 years ago
Roland, nothing is "blocking" this except for leaf's time (or your time if you
want to make nightly source tarballs for us). 
(Reporter)

Comment 7

16 years ago
Asa Dotzler wrote:
> Roland, nothing is "blocking" this except for leaf's time (or your time if you
> want to make nightly source tarballs for us).

I would need an account for ftp.mozilla.org (or stage.*.* or whatelse is
currrently be used) to push the archives to the server...

Comment 8

16 years ago
Roland, yes, you would. If you're interested in contributing nightly source
tarballs and you think you'll get to it sooner than leaf then let leaf or dawn
endico know and they'll see about getting you set up with access to stage those
bits. 
(Reporter)

Comment 9

16 years ago
Asa Dotzler wrote:
> If you're interested in contributing nightly source
> tarballs

And Solaris/SPARC binary nightlies... :)

> and you think you'll get to it sooner than leaf then let leaf or dawn
> endico know and they'll see about getting you set up with access to stage 
> those bits.

OK, what have I to-do to get stage access ?

Comment 10

16 years ago
I would love to have either a solaris binary (compatible w/ sol 2.6) or the
source to make my own binaries.  CVS access isn't convenient due to my friendly
firewall at work.
(Reporter)

Comment 11

16 years ago
yorgasor wrote:
> I would love to have either a solaris binary (compatible w/ sol 2.6)>

Sorry, I can only provide binaries which work on Solaris 2.7 or higher...

Updated

16 years ago
Target Milestone: Phoenix0.4 → Phoenix0.5
*** Bug 175934 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Target Milestone: Phoenix0.5 → Phoenix0.6
(Reporter)

Comment 14

16 years ago
Taking bug myself, I have finished the neccesary tarball generation and
verification scripts and now I am waiting for a stage account (bug 188135) ...
Assignee: leaf → Roland.Mainz
Depends on: 188135
*** Bug 188034 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
Perhaps nightly source tarballs are too much effort but maybe you could provide
source tarballs just for milestone releases.
(Reporter)

Comment 17

16 years ago
1. I am waiting for the OK from the Phoenix gods to upload nightly phoenix
source tarballs and Solaris/SPARC binaries
2. For now I am generating the phoenix source tarballs as *.tar.bz2 under
http://puck.informatik.med.uni-giessen.de/people/gisburn/work/mozilla/phoenix/nightly/
until they are uploaded to ftp.mozilla.org directly (but I cannot archives more
than three days due disk space limitations)

Comment 18

16 years ago
why don't you just tar mozilla/browser and mozilla/toolkit ?
source of the trunk are already available in ftp.mozilla.org.
(Reporter)

Comment 19

16 years ago
pch wrote:
> why don't you just tar mozilla/browser and mozilla/toolkit ?
> source of the trunk are already available in ftp.mozilla.org.

The source tarball should be a _snapshot_ of the CVS at a given time (like a CVS
pull by date).
Just making a tar.gz from mozilla/browser and mozilla/toolkit is problematic
since the script which creates mozilla-source.tar.gz may use a different time
(or works in a different timezone) - which is likely to cause problems for the
one who tries to compile a working phoenix from the unpackted tree...
Shifting to 0.7 to clear out our milestone buglists. 
Target Milestone: Phoenix0.6 → Phoenix0.7
Summary: RFE: Create nightly source tarballs for phoenix → RFE: Create nightly source tarballs for Mozilla Firebird

Updated

16 years ago
Target Milestone: Firebird0.7 → ---

Updated

15 years ago
QA Contact: asa

Comment 21

15 years ago
Can we target this for Firebird0.8? I think getting nightly source tarballs with
an official .mozconfig (with the minimum options required to produce a Firebird
build) in place would be a big win for getting Firebird more widely adopted.
Right now getting CVS to work, especially on non-Linux platforms, is not very
intuitive.

Comment 22

15 years ago
CVS Works fine on many non Linux platforms :)

Comment 23

15 years ago
In response to comment 22, I'm well aware that CVS works on most platforms. I
personally use it on Windows daily and I don't have a problem with it.

The main thrust of my comment was that on non-Linux platforms, Windows included,
CVS is not intuitive to set up (though it works fine when properly set up).

I made the comment I did not to make things easier for myself, but in order to
lower the bar to entry for people to build the Firebird source and thus increase
exposure.

If source tarballs are not useful, then why bother producing them for Seamonkey?
Clearly, they have a function.

Sorry for bugspam, but I just couldn't let that comment go unanswered.

Comment 24

15 years ago
I've written a script to pull the source for Firebird and Thunderbird from CVS
and  create a tarball. Its set to run at 22:02 GMT every night. The thread on
mozillazine is here http://forums.mozillazine.org/viewtopic.php?t=38176

The tarballs are available from
http://matrix.netsoc.tcd.ie/~maxhead/mozilla-source/ for now 

Hopefully this will help until Roland gets back.

Comment 25

15 years ago
Tinderboxes are constantly pulling source.  Now that we have them (and ftp
mirrors), can we designate one of each kind to also make tarballs to upload?
Roland, what's the status on this?  You've had stage access for a good long time
now...
Severity: normal → enhancement
Summary: RFE: Create nightly source tarballs for Mozilla Firebird → Create nightly source tarballs for Mozilla Firebird

Comment 27

15 years ago
I'm generating tarballs with sources for thunderbird and firebird (tar.gz and
tar.bz2) regularly (http://matrix.netsoc.tcd.ie/~maxhead/mozilla-source) and am
willing to contribute them to mozilla.org if needed. (I have limited space at
the moment and can only hold about 3 days worth of tarballs).

Lemme know if anyone's interested...

Comment 28

15 years ago
Reassigning to Leaf per bryner on IRC.  

Leaf-
Please add Firebird and Thunderbird to the Seamonkey tarballs.  bryner will make
symlinks in the Firebird/latest and Thunderbird/latest directories.
Assignee: Roland.Mainz → leaf

Comment 29

15 years ago
directories to add are browser, chrome, mail, and toolkit

Updated

15 years ago
Summary: Create nightly source tarballs for Mozilla Firebird → Create nightly source tarballs for Mozilla Firefox

Updated

15 years ago
Alias: phoenix_src_tarball → firefox_src_tarball

Comment 30

15 years ago
Has anything happened on this yet? I'm just wondering if I still need to leave
my script running :)

Updated

14 years ago
Assignee: leaf → cmp
Priority: -- → P3

Comment 31

14 years ago
Now that Firefox / Thunderbird are our flagship products, can we get this set up?

Moving over to mozilla.org:Server Ops, where this probably should be.

If not separate tarballs, then at least one tarball that contains enough to
build all of these.
Assignee: cmp → justdave
Component: General → Server Operations
Product: Firefox → mozilla.org
QA Contact: myk
Summary: Create nightly source tarballs for Mozilla Firefox → Create nightly source tarballs for Aviary Products (Firefox / Thunderbird)
Version: unspecified → other

Comment 32

14 years ago
Reassigning back to cmp@mozilla.org, since this probably falls under his domain
anyway.
Assignee: justdave → cmp

Comment 33

14 years ago
This is a good idea for once we get our large disk array configured.  It's
unlikely this will happen until then since we need to remove nightly builds once
every 5-7 days just to keep the automation ship sailing.
(In reply to comment #33)
> This is a good idea for once we get our large disk array configured.  It's
> unlikely this will happen until then since we need to remove nightly builds once
> every 5-7 days just to keep the automation ship sailing.

OK, we have our big disk array now.  status?

Comment 35

13 years ago
(In reply to comment #34)
> OK, we have our big disk array now.  status?

This is low on the list -- it's up against staying on top of releases (which we're behind on) and the new 1.8.0 branch.  CC'ing Paul.

Paul or Dave, if either of you can tackle this, proceed by checking out egg and it's nightly source tarball automation.  Create a copy of it for the branches you want to pull/upload and add the command to cltbld's list of cron jobs.  Let me know if you have any questions.
Justin is now the QA for this component.
QA Contact: myk → justin
Component: Server Operations → Build & Release
QA Contact: justin → chase

Comment 37

13 years ago
Mass reassign of open bugs for chase@mozilla.org to build@mozilla-org.bugs.
Assignee: chase → build
Mass re-assign of bugs that aren't on the build team radar, so bugs assigned to build@mozilla-org.bugs reflects reality.

If there is a bug you really think we need to be looking at, please *email* build@mozilla.org with a bug number and explanation.
Assignee: build → nobody
*** Bug 350344 has been marked as a duplicate of this bug. ***
QA Contact: chase → preed
QA Contact: mozpreed → build
Does anyone still think this would be useful?

Comment 41

11 years ago
Yes, but I don't think we need it daily... once a week would be sufficient.
I believe rhelmer mentioned that this might be easy with some of the buildbot work he was doing.  He had all three platforms building from a single source tarball, iirc.
Ted: Yeah, that's what I was thinking too. We also have the Source(.pm) tarball step as part of Bootstrap which could be deployed as part of bug 401936.
The source tarball is being generated as part of the 1.8 automation. Fixing 401936 would give us a source tarball for nightlies.
Depends on: 401936
Not doing this immediately, but as comment 44 states we'll be able to do this as part of bug 412780. 
Assignee: nobody → rhelmer
Whiteboard: waiting on buildbot+nightlies
Nothing to do here yet, returning to pool.
Assignee: rhelmer → nobody
Component: Release Engineering → Release Engineering: Future
QA Contact: build → release
So bug 401936 was fixed (which is what I meant to say in comment 45), but bhearsum's comment is that only 1.8 nightlies and not 1.9 will be moved to the release automation system.

I followed to bug 421411 which states that 1.9 is staying on Tinderbox, which I guess blocks this bug there.

I would suggest at this point just getting this going on the trunk and ignoring 1.8/1.9, if nightly source tarballs are still desirable.
Is there still demand for this now that we've moved to hg? Are the same people who were unable to pull source via CVS still stymied by mercurial?

If there *is* still demand for this, what should be the frequency? Daily? Weekly?
(In reply to comment #49)
> Note that you can get a tarball or zip of *any* revision with links like:
> http://hg.mozilla.org/mozilla-central/archive/tip.tar.bz2 or
> http://hg.mozilla.org/mozilla-central/archive/db76f7da877d.tar.bz2

OK, that's awesome, and certainly enough to close this bug. 

Given the lack of active development on 1.9.0, I think the source tarballs that we provide with each release are sufficient for that branch.

I'll make sure the relevant info sources on the wiki/MDC mention how to grab these bundles.
Status: NEW → RESOLVED
Last Resolved: 16 years ago10 years ago
Resolution: --- → FIXED
Moving closed Future bugs into Release Engineering in preparation for removing the Future component.
Component: Release Engineering: Future → Release Engineering
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.