Closed Bug 1759796 Opened 11 months ago Closed 11 months ago

Removing Cookies and Site Data clears more disk cache than it should

Categories

(Toolkit :: Data Sanitization, defect)

Firefox 99
x86_64
Windows 10
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: 6k64x4ma, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:99.0) Gecko/20100101 Firefox/99.0

Steps to reproduce:

  1. Create clean profile on nightly
  2. Open https://twitter.com/
  3. Open https://commons.wikimedia.org/
  4. On wikimedia open "Random file" link many times to collect cache
  5. Open about:cache and check "Number of entries" and "Storage in use"
  6. Open about:preferences#privacy and delete cookies for twitter.com
  7. Reload about:cache and check "Number of entries" and "Storage in use"

Actual results:

Almost all caches are purged.

Expected results:

Only caches associated with twitter should be deleted.

mozregression:
2022-03-16T12:05:47.990000: DEBUG : Found commit message:
Bug 1712170 - Update preferences siteData dialog to list entries by base domain. r=johannh

Differential Revision: https://phabricator.services.mozilla.com/D116863

2022-03-16T12:05:47.990000: DEBUG : Did not find a branch, checking all integration branches
2022-03-16T12:05:48.006000: INFO : The bisection is done.
2022-03-16T12:05:48.006000: INFO : Stopped

OS: Unspecified → Windows 10
Regressed by: 1712170
Hardware: Unspecified → x86_64
See Also: → 1591362

Set release status flags based on info from the regressing bug 1712170

:pbz, since you are the author of the regressor, bug 1712170, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(pbz)

I am sorry, I made a mistake.

Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → INVALID
Has Regression Range: --- → yes
Flags: needinfo?(pbz)
No longer regressed by: 1712170
Has Regression Range: yes → ---
Keywords: regression
You need to log in before you can comment on or make changes to this bug.