Closed Bug 1760540 Opened 8 months ago Closed 8 months ago

Remove unused `fromPreview` parameters

Categories

(DevTools :: Console, task)

task

Tracking

(firefox100 fixed)

RESOLVED FIXED
100 Branch
Tracking Status
firefox100 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

Details

Attachments

(1 file)

Looks like it was used for WebReplay and wasn't cleaned-up properly

https://searchfox.org/mozilla-central/search?q=forPreview&path=devtools%2F&case=true&regexp=false

Looks like this is a leftover from WebReplay.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/30f81a7041c7
[devtools] Remove unused `forPreview` parameters. r=ochameau.

Backed out 3 changesets (bug 1759666, bug 1760541, bug 1760540) for causing talos damp failures.

Backout link: https://hg.mozilla.org/integration/autoland/rev/270fdfb511cfab2286f4d52fdfde34bc762b7938

Push with failures

Failure log

 Start "console.log-in-loop-content-process-infinity"
[task 2022-03-22T20:50:29.552Z] 20:50:29     INFO -  PID 19227 | Garbage collect
[taskcluster:error] Aborting task...
[taskcluster:warn 2022-03-22T20:50:31.878Z] no such process
Flags: needinfo?(nchevobbe)
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/707a27013bc3
[devtools] Remove unused `forPreview` parameters. r=ochameau.

failure not caused by this patch

Flags: needinfo?(nchevobbe)
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
You need to log in before you can comment on or make changes to this bug.