Closed Bug 1760541 Opened 2 months ago Closed 2 months ago

Don't reuse longString actors

Categories

(DevTools :: Console, task)

task

Tracking

(firefox100 fixed)

RESOLVED FIXED
100 Branch
Tracking Status
firefox100 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

Details

(Whiteboard: dt-console-perf-2022)

Attachments

(1 file)

In createValueGrip (devtools/server/actors/object/utils.js#123), we check if a longString actor was already created for the passed string so we can reuse it.
This can be dangerous if multiple panels end up using the same fronts and one of the panel releases it while the other expect it to be alive.
It's also a performance issue as we're searching through all the created actors, and can take a while if we have lots of them.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d0c9fc3a8d87
[devtools] Don't reuse longString actors for same string.r=ochameau.

Backed out 3 changesets (bug 1759666, bug 1760541, bug 1760540) for causing talos damp failures.

Backout link: https://hg.mozilla.org/integration/autoland/rev/270fdfb511cfab2286f4d52fdfde34bc762b7938

Push with failures

Failure log

 Start "console.log-in-loop-content-process-infinity"
[task 2022-03-22T20:50:29.552Z] 20:50:29     INFO -  PID 19227 | Garbage collect
[taskcluster:error] Aborting task...
[taskcluster:warn 2022-03-22T20:50:31.878Z] no such process
Flags: needinfo?(nchevobbe)
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/01e704140fff
[devtools] Don't reuse longString actors for same string.r=ochameau.

failure not caused by this patch

Flags: needinfo?(nchevobbe)
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
You need to log in before you can comment on or make changes to this bug.