Closed Bug 1762394 Opened 2 months ago Closed 2 months ago

persist menu creation in startupCache

Categories

(WebExtensions :: General, enhancement, P1)

enhancement

Tracking

(firefox101 fixed)

RESOLVED FIXED
101 Branch
Tracking Status
firefox101 --- fixed

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

References

(Blocks 1 open bug)

Details

(Whiteboard: [addons-jira])

Attachments

(1 file)

For MV3, Any menu creation/update needs to be stored in startupCache and recreated on startup of an addon.

Add a StartupCache for menus created during runtime.onInstalled

Duplicate of this bug: 1754859
Blocks: 1587876
See Also: → 1748535
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9158cfea7912
menu startupCache persistence r=robwu
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 101 Branch
You need to log in before you can comment on or make changes to this bug.